I've set

public $error_reporting = 'maximum';
public $debug = '1';

If I go into cPanel and turn off mysqlnd nd_mysqli and nd_pdo_mysql and then turn on mysqli I get an error

MySQL server has gone away

But switching them back on gives me 503 Service Unavailable instead. Which is less of an error message.

Here's the full error I can get to show up from debug:


in /home/*********/public_html/libraries/src/Application/AdministratorApplication.php (line 265)
            )                ->bind(':style', $admin_style, ParameterType::INTEGER);        }        $query->order($db->quoteName('s.home'));        $db->setQuery($query);        $template = $db->loadObject();        $template->template = InputFilter::getInstance()->clean($template->template, 'cmd');        $template->params = new Registry($template->params);

And one from the error reporting maximum

Warning: session_write_close(): Failed to write session data using user defined save handler. (session.save_path: /opt/alt/php81/var/lib/php/session) in /home/******/public_html/libraries/vendor/joomla/session/src/Storage/NativeStorage.php on line 114
  • 1
    What do you have set for your Session Handler, Filesystem or Database? The last message you have quoted looks to me like it is set to Filesystem and there is an issue with folder, maybe permission. I don't think you can use mysqli with Joomla 4 which might explain the server gone away message.
    – Irata
    Commented Jul 21, 2022 at 11:18
  • I thought the same which is why I was trying to change it. I think it's a hosting issue, it comes back after a while. Simply changing things seem to crash it so perhaps it is cached in the browser for some reason.
    – Eoin
    Commented Jul 22, 2022 at 8:22

1 Answer 1


I managed to solve this by setting up the myqsl_nd_pdo module in PHP

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.