0

I have built a directory website and started to add some content. I have created the standard pages (contact us, privacy, etc.) and added businesses. I would like SEO-friendly URLs, so I set:

  • Search Engine Friendly URLs
  • URL Rewriting - YES
  • Suffix - No

However, Joomla somehow rewrites my aliases and changes them.

For example: mywebsite/bar-and-dinner is displayed as mywebsite/bar-din-r.

I contacted the support of the plugin I use and they told me that I must have had some filters on Joomla that creates such a problem. I tried to purge the cache on the website & server, but it's still the same. I just updated to Joomla 4.0.

What can I do to prevent the corruption of my SEO-friendly URLs?

3
  • Welcome to JSE and thank you for asking your question, @33money. Please take our tour while you wait for feedback/support. Please avoid adding irrelevant text to posts such as "Good afternoon", "Thanks for reading", "I'm new", "I need help", "I would be really appreciative", "Thanks in advance", "My name is 33money", etc. You haven't done all of these things, but this is an opportunity to inform readers that we only want the relevant bits in the question body. This makes a better, faster research experience for future readers (especially ones with visual impairments).
    – mickmackusa
    Apr 27 at 22:38
  • What is the plugin you mention that you use? If you disable the plugin are the URL's displayed as you expect?
    – Irata
    Apr 28 at 1:50
  • Hi, I am using JB plugin. However, I disabled it but the problem is still there. I've noticed the URL is rewritten when I have words with double "n", "a" and "e" (in my non English language).
    – 33money
    Apr 28 at 11:02

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.