0

I am using a Joomla! 3.10.8 Stack from Turnkey Linux, it shows a warning, that I have to upgrade to a higher PHP-version. So how I update/upgrade the higher PHP-version? And is it clever to upgrade to PHP 8 already?

TYVM for answers!

2
  • What version of PHP are you running now, 5.x or 7.x?
    – Irata
    Apr 22 at 3:36
  • im currently running 7.3
    – Albert
    Apr 22 at 5:42

1 Answer 1

2

I believe you need to make sure all your extensions and components are upgraded to php8, then you can change it in your cpanel under MultiPHP Manager. I was able to simply switch it over. I get an error but clearing the browser cache sorts this. You also need to ensure your server has PHP8 installed along with the necessary extensions, I am on a dedicated server so I am able to do this myself. If not, get your hosting provider to do it.

I had a bit of trial and error to start with but got there (and it is well worth it).

6
  • Thanks for contributing Malc. Please take our tour.
    – mickmackusa
    Apr 22 at 3:52
  • I somehow still get the "error" and a blank site, even after deleting the cache.
    – Albert
    Apr 22 at 12:05
  • Go to extension manager and select All under the number of pages. Take a screen shot or video capture of all published/unpublished extension or copy and paste in a spreadsheet or something (it will be quicker to restore later).
    – Malc
    Apr 23 at 14:54
  • Next disable every single none core joomla extension/modules/plugins. Then switch the first component on, refresh screen, if it loads, then proceed to enable each plugin, each time checking the screen. You can also do this for modules as you may have one that is outdated but not deleted from a while back. Do these steps for the rest of your components. When you find the culprit, keep it disabled or get the updated J4 version from the developer. This should work
    – Malc
    Apr 23 at 14:57
  • You can use the screen capture to see if there are any components, modules or plugins that were disabled before the process and also disable them again
    – Malc
    Apr 23 at 14:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.