1

We have Joomla 3.3.6 , I am aware of the following link https://downloads.joomla.org/technical-requirements

We are planning to Upgrade DB version to 9.6 which is also at EOL by Nov 2021 because Joomla support matrix only states 9.1+ for Postgres operability. We are uncertain at the moment if Joomla will work with a 10.x or above Postgres release.

This question is related to Joomla 3.3.6 with Postgresql on JSE.

1
  • Welcome Faisal, please take our tour while you wait for feedback/support.
    – mickmackusa
    Jun 28 at 22:13
1

I would read the document you have linked to as 10.x being supported as 9.1+ means anything above 9.1 is okay. A look through the code of PostgreSQL doesn't show up any mention of limitation specific to a version and it appears to gracefully give you a 'is not supported' message if it is not able to handle a particular statement.

I would expect that you would have some sort of test environment set up with a copy of your site and PostgreSQL 10.x installed to confirm it for yourself beforehand.

Further down the page in your link Joomla 4 has PostgreSQL 11.0 as the minimum level so again I would expect Joomla 3.x to support 9.1 and all of the 10.x levels.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.