0

I have a site set up that allows the user to login to a secure area. Everything works.

I'm having a problem with the email address. The user registers with an email address which works fine. However they can then edit their profile which offers them the chance to edit their email address.

They can change and save the email in the profile. But when I look in the admin area the user email remains the registered email address and I can't find where the new email address (created in the profile) is stored. It is obviously stored somewhere because when I log out and log back in and goto /login/profile the email address is the new one.

Can someone tell me what's happening.

thanks

UPDATE

So I've looked into this and it seems to be an microsoft edge issue. Firefox and brave seem okay.

I can replicate it on Edge every time and it works fine everywhere else. So I think the comment about some sort of cache issue is probably right but I haven't quite found it yet. Seems a bit mad that I can't switch off the editing profile capability - it'd be simple enough to write my own

3
  • Depends on which one they edit. If you're creating a contact for users as they register, the email might be getting stored in #__contact_details.email_to be keyed on user_id = #__users.id. If what they're editing is a custom field, it'll be stored in #__fields_values.value and keyed on item_id = #__users.id.
    – Michael
    Sep 14 '20 at 20:46
  • Do you know where I'd find that field in the admin interface Sep 14 '20 at 20:50
  • If it's a contact field, you'll find it in Components > Contacts If it's a custom field, you should see it when editing the user.
    – Michael
    Sep 14 '20 at 21:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.