1

My joomla is version: 3.2.7 and Gantry is 4.1.20.

I downloaded Gantry 4.1.32, but when I tried to update, this message appears:

Fatal error: Call to undefined method JInstallerAdapterPackage::getManifest() in /home/storage/4/c7/38/googeek3/public_html/portal/tmp/install_5f11bc9c68387/install.php on line 75

I'm running Joomla in PHP5.6.

I have another website hosted in the same host since 2016 and updates are running fine!

They have the same configuration and I don't know what's happened.

Both templates use JoomSocial (full template without JoomSocial plugin).

  • Welcome to JSE, please take our tour while you wait for support. Please continue to research and attempt to self-solve. If you manage to self-solve, please post an educational answer for the benefit of future researchers. – mickmackusa Jul 17 at 15:16
  • No one should be running sites on PHP5.6 anymore. You should prioritise upgrading your php to a supported version. – mickmackusa Jul 17 at 15:17
  • It might help to clarify if you are upgrading the Gantry Template or the Gantry Framework or both. – Neil Robertson Jul 18 at 1:29
0

Gantry v4.1.32 was the last supported version for Joomla 2.5.

I suggest trying to install the latest version of Gantry for Joomla 3.x which is Gantry v4.1.43.

Ideally, you should also also be updating Joomla and PHP (and any other third party extensions) to the latest versions.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.