0

First, some background information...

I am a medical doctor, not a professional webdev, and I am not very experienced with Joomla. I have only used Wordpress in the last few years for some random content.
That said, I have recently been "asked" to take care of a website for a researcher group (I don't know how else to describe it).

The website was previously administered by a webdev working in another country, who hosted the website on a private server. He told me all the requirements and we managed to find a hosting service which would support the previously built website (mostly concerning php and mySQL).

He sent me the backup of the website and db, we registered the domain transfer, and once everything was done we were hoping everything would work. Of course, we were dead wrong.

I have fixed the configuration.php file, but even after moving everything this message shows up:

Warning: require(/web/htdocs/website_url/home/libraries/vendor/composer/../joomla/string/src/phputf8/utf8.php): failed to open stream: No such file or directory in /web/htdocs/website_url/home/libraries/vendor/composer/autoload_real.php on line 66

Warning: require(/web/htdocs/website_url/home/libraries/vendor/composer/../joomla/string/src/phputf8/utf8.php): failed to open stream: No such file or directory in /web/htdocs/website_url/home/libraries/vendor/composer/autoload_real.php on line 66

Fatal error: require(): Failed opening required '/web/htdocs/website_url/home/libraries/vendor/composer/../joomla/string/src/phputf8/utf8.php' (include_path='.:/php7.2/lib/php') in /web/htdocs/website_url/home/libraries/vendor/composer/autoload_real.php on line 66

I have no idea how to solve this issue and it's really getting on my nerves. The webmaster is very supportive and is (hopefully) trying to find a solution as well, but so far he hasn't been able to solve this issue either.

Is there anybody willing to help me in this situation? :-(

5
  • From the error it looks like that the problem has not much to do with Joomla but the wrong server settings. Please ask your web host to check the correct server settings. (Maybe, you can also check your configuration.php file in Joomla root folder but I do not think that it causes this error...)
    – Zollie
    Jun 16 '20 at 7:55
  • Thank you for joinin JSE. Please take our tour.
    – mickmackusa
    Jun 16 '20 at 8:30
  • Before someone totally misunderstand this issue. Composer is part of Joomla 3.x.x CMS. Composer is not missing in this case. Composer’s autoloader class in Joomla is used to load a lot of files together with core Joomla files and together with the core Joomla JLoader class. The Composer’s Loader is called by cms.php immediately at the start of Joomla. At this issue, this Composer AutoLoader tries to load utf8.php file from it’s Map but it does not find it, most probably because the Joomla’s site path in the webserver is set in a wrong way, or Joomla is installed in a wrong directory...
    – Zollie
    Jun 16 '20 at 18:51
  • That is why I wrote that this is not a Joomla issue, but wrong server settings issue which we cannot see and check...
    – Zollie
    Jun 16 '20 at 18:53
  • 1
    And as I see it on Joomla Forum, the issue was solved by using Akeeba backup for the old site and by installing it using Akeeba kickstart and the site worked again on the new host without any problem. So there was no any file missing or no anything wrong with Joomla. Well, here we can also learn that if someone says: “I moved everything”, “and I fixed the configuration”, then we can know that these does not mean anything. link to the solution: forum.joomla.org/viewtopic.php?t=980666&p=3607323 - well, at least the issue was solved...
    – Zollie
    Jun 17 '20 at 15:22
2

In the end I managed to solve the issue by simply re-creating the page locally (using MAMP), generating an Akeeba backup, and restoring the backup via Kickstart. I really have no idea why this happened in the first place.

1
  • could you please accept your own answer so we can see this is solved and may be easier for someone with a similar issue to find it in the future.
    – Irata
    Jun 21 '20 at 22:52
1

So there could be an issue with the new hosting if it’s alao a custom solution in that it doesn’t have a tool called composer installed.

What I’d recommend:

Patrick

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.