Joomla! does not recognize my module update, so I decided to create a blank module to see if it suffered the same issue -- it did.

When I search for updates my mod_extension is not visible in the list for available updates.

Here are my files:


        <name>extension name</name>
        <description>extension description</description>
        <infourl title="Local Info Page">http://updates.local/info.html</infourl>
            <downloadurl type="full" format="zip">http://updates.local/mod_extension.zip</downloadurl>
        <maintainer>local tester</maintainer>
        <targetplatform name="joomla" version="3.[0123456789]" />

And my mod_extension.xml:

<extension type="module" version="3.5" client="site" method="upgrade">
    <creationDate>December 2019</creationDate>
    <license>GNU General Public License version 2 or later; see License.txt</license>
    <authorEmail>[email protected]</authorEmail>
        <server type="extension" priority="1" name="mod_extension">http://updates.local/test_extension.xml</server>
        <filename module="mod_extension">mod_extension.php</filename>

Edit: Joomla does not show the update. XML File & Zip File are accessible by URL.

  • When you say it's not updating, what do you mean by this? It's not detecting the update? It's showing an error when trying to update the file?
    – Lodder
    Commented Apr 21, 2020 at 9:54
  • yes - i've cleared the cache already - xml file and zip file are accessible
    – Marco
    Commented Apr 21, 2020 at 9:55
  • Which one is it though? What do you mean by it's not updating?
    – Lodder
    Commented Apr 21, 2020 at 9:59
  • i've edited my question. When i search for updates my mod_extension is not visible in the list for available updates.
    – Marco
    Commented Apr 21, 2020 at 10:01

1 Answer 1


You have to add a client element in your updater xml:


Joomla seems to take the admin as the default.

I tried out your xml and found that joomla was indeed finding the xml file ok and even inserting a record into the #__updates table. However because your module is a site module and the update xml didn't have the client element there, it wasn't matching the update to your extension.

When I added the client element it worked fine. (Although you may need to clear the cache to get it to look for that update again).


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.