1

I tried to duplicate an administrator menu, but this is not possible due to a missing "apply" button.

Is there any settings or circumstances where this can happen?

I recorded a little gif to demonstrate what I mean:

enter image description here

  • 1
    I found this issue on the Joomla Tracker: github.com/joomla/joomla-cms/pull/22178 which looks as if it's relevant. And there are some other issues on the same topic. I think it's because you've got an unpublished menu item there. If you click on Search Tools and then set the status search box to Published and then try and do the batch operation the button appears ok. But when I leave the search box empty and just select published menuitems it still doesn't work. It looks as if there's still some bug in Joomla there so you might want to raise an issue on the tracker. – Robbie Jackson Apr 18 at 21:13
  • Yeah could be that too @RobbieJackson. The first thing I thought of was the button is missing in the default_batch_footer.php file. – Thiago Guimarães Apr 19 at 11:15
  • @RobbieJackson this worked for me, thanks! :-) – AndiLeni Apr 22 at 11:51
0
  1. Locate the file default_batch_footer.php in /administrator/components/your-component/views/your-view/tmpl/

  2. Open the file.

  3. Add this code:

        <button class="btn btn-success" type="submit" onclick="Joomla.submitbutton('your-view.batch');">
            <?php echo JText::_('JGLOBAL_BATCH_PROCESS'); ?>
        </button>
    

    (rename your-view with the name of your view)

  4. Save the file.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.