0

Remove /index.php from joomla 3x, I enable rewrite it removes the /index.php but leads to error 404 please advise except for the home page. Please help fix this.. thanks in advance.

2
  • Rename htaccess.txt to .htaccess but no changes... Anything that will work I highly welcome – alfred atsaba Apr 7 '20 at 8:41
  • 1
    Your comment only alerted me because I am the only user to comment under your question. To respond to the answerers, leave a comment under their answers -- this way they will receive a notification. – mickmackusa Apr 7 '20 at 9:29
0

Rename htaccess.txt to .htaccess

1
  • This answer has been auto-flagged as Low-quality. Please try to be more generous about what this does and why it is a good idea. I realise you are making a very basic/intuitive/self-explanatory suggestion, but it role models better posting behaviours and stands to empower/educate more researchers if you can explain your solution. – mickmackusa Apr 6 '20 at 2:54
0
  1. Rename htaccess.txt to .htaccess (as @Midhat said)

    htaccess is needed to make your urls friendly. It comes with a ."txt" extension by default.

  2. Make sure your server has mod rewrite on

    To enable mod rewrite open your httpd.conf file (in your server folder) search for mod_rewrite. If there's any "#" in front of mod_rewrite, take it out and save the file

  3. Make sure your httpd.conf is correctly configured

    it may be hard to find the correct configuration for the httpd.conf file, so after following the first two steps above, and you still get the error, i suggest you either changing your local server (if it's a local host) or contacting your hosting service to check the server configuration

0

Depending on the host of your website, there can be several solutions.

First, as already mentioned, rename the htaccess file.

If this proves to be unsuccessful:

  1. Look into the system information tab and be sure that you're on an apache system and not on nginx. Because htaccess only affects Apache. Otherwise, you need to configure nginx.

  2. If you're on Apache, check the rewrite base within the htaccess and remove the #. Or have a call with your hosting service provider to be sure that there is no other configuration necessary for the rewrite base.

1
  • Welcome to JSE, Holger. Thank you for contributing! Please take our tour and see if you can add value to any other questions. – mickmackusa May 4 at 8:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.