0

I've just installed a number of captcha extensions and they all show "Captcha * (optional)" next to the form's Submit button. Is there any way to prevent the word 'optional' from displaying? The input is required.

1

The form which displays the captcha will have a label field which will be set to a Joomla language constant. You need to find the form xml definition, and then find the label for the captcha to get the name of the language constant. Then change the text associated with that language constant in the appropriate language .ini file.

If for some reason you can't change the language ini file then you can create an override as described in https://docs.joomla.org/J3.x:Language_Overrides_in_Joomla, by going into admin Extensions / Language(s) / Overrides, clicking on New and setting a different text string for your captcha label.

Actually, going into the admin Extensions / Language(s) / Overrides, and then clicking New, and on the right hand side Search for Value and entering "Captcha * (optional)" is also an easy way of finding the language constant you want.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.