0

On the Admin panel (and apparently only there), I got the following error:

Call to a member function format() on null

The rest of site and the administrator are working fine.

It's Joomla 3.8.2 running on php 7.0.33.

I haven't made any update on the site since its configuration. So unless there was a silent update from Joomla, update of the environments by my provider or hacking, I've no clue what may have happened.

I tried to find a log, but couldn't find any log file reporting the error.

I tried to activate the debug (public $error_reporting = 'maximum'), but it activates it only in the front-end.

9
  • Are you able to provide the rest of the message that should show what was being called and from where? You may have to change the Error Reporting Level in the Global Config to Maximum or development. – Irata Feb 20 '20 at 20:56
  • Welcome to JSE @Ivr. Please take our tour, consider introducing yourself and your experience with Joomla in your profile, and responding to Sharky's recommendation. – mickmackusa Feb 20 '20 at 22:12
  • Hard telling from that information. If you can get to the webserver's error log you may find more info. Also, if you're running php as a cgi process(as in php-fpm) then there may be a log entry for it there. What you need is a filename and a line number for that error; without that all we can do is guess at which object was null when format was called. – Arlen Feb 20 '20 at 23:03
  • Fixed by changing the eos dates in the phpversioncheck. Next for me : update to the newest version of Joomla on my dev environment, and check how to run a newer version of PHP. Thanks. – lvr123 Feb 22 '20 at 13:53
  • By the way, how to activate the debug on the administrator part ? Neither public $error_reporting = 'maximum' nor public $error_reporting = 'development' are changing anything... – lvr123 Feb 22 '20 at 13:56
0

If a more meaningful error message can't be found, it may be difficult to provide an accurate solution.

In the meantime, and since you don't mention any impediment to upgrading, you may be able to solve the issue by doing some or all of the following:

  1. take a backup of the website before making any changes (I like the free or paid version of Akeeba Backup)
  2. update all third party extensions to the latest versions
  3. update Joomla to the latest version
  4. try updating PHP to a supported version

Even if this does not solve the issue, it is usually easier for volunteers and extension developers to support the latest version of Joomla and extensions rather than trying to recreate a combination of outdated versions to troubleshoot the problem.

Not the answer you're looking for? Browse other questions tagged or ask your own question.