0

I have an issue here where I have already added line below into .htaccess file, AllowOverride all in httpd.conf file, enabled Use URL Rewriting from Joomla, but none of those work. Did I miss out anything or are there anything wrong with below line? I'm kind of out of idea now :((

RewriteEngine On
RewriteCond %{HTTP_HOST} ^abc.com [NC] 
RewriteRule ^(.*)$ https://www.abc.com/$1 [L,R=301]
  • if you put some random chars in this htaccess file does your site throw a 500 error? If not then you know that it isn't being looked at. Also, did you try ^abc\.com with a backslash? It usually doesn't matter but may as well try it. – jamesgarrett Feb 11 at 7:30
  • @jj9 while you wait for answers/feedback, please take the tour and consider editing your profile to introduce yourself to the community. – mickmackusa Feb 11 at 7:42
  • @jamesgarrett Nope, did not throw up any error as well. So it means it not even read .htaccess file? – Petri Feb 11 at 9:27
  • @mickmackusa Noted will update accordingly. – Petri Feb 11 at 9:27
  • apache config files are "last setting wins" so is it possible there's another AllowOverride directive that could apply to this later in the config after the "all" that changes it? – Arlen Feb 11 at 14:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.