3

I went into the "configuration.php", changed error reporting to "maximum", and now my Joomla admin page is suddenly blank white.

Then when I go to my backend login page, I get the following error messages:

Notice: Undefined variable: recommendedVersion in /home/mchardism/public_html/plugins/quickicon/phpversioncheck/phpversioncheck.php on line 173

Notice: Undefined variable: recommendedVersionEndOfSupport in /home/mchardism/public_html/plugins/quickicon/phpversioncheck/phpversioncheck.php on line 174

Fatal error: Call to a member function format() on null in /home/mchardism/public_html/plugins/quickicon/phpversioncheck/phpversioncheck.php on line 174

So when I go to the phpversioncheck.php, lines 173 and 174, I see this:

enter image description here

And this is where I'm stuck. I don't know what I need to change in these lines to fix the issue. I've never opened this phpversioncheck.php file before and I'm not sure why it is suddenly giving me issues.

I am using: Joomla 3.6.5

  • Welcome to JSE. Would you be able to provide the contents of the entire file? – Lodder Dec 9 '19 at 21:24
  • You should not give too much attention to this error (this is just a PHP version check in this plugin), but you should update Joomla to the latest version and most probably this error will disappear. Joomla 3.6 is quite outdated. Why have you turned on maximum error reporting by the way? – Zollie Dec 9 '19 at 21:52
  • I googled the white admin screen issue and saw a number of different posts suggest setting the error reporting to "maximum." I generally don't know what I'm doing. – Dave_M Dec 9 '19 at 21:59
  • @Lodder Which file are you referring to? – Dave_M Dec 9 '19 at 22:01
  • Ohh, I understand it now. There was already an error (with the white screen) and then you turned on maximum error reporting. Probably the server is using a newer PHP version and Joomla 3.6 does not support that PHP version. Maybe the PHP version has to be set back to PHP 5.6 and then a lot of updates, but it is better if you ask someone expert to help you with updating your Joomla site. – Zollie Dec 9 '19 at 22:05
5

In order to fix it, open /home/mchardism/public_html/plugins/quickicon/phpversioncheck/phpversioncheck.php, find between the lines #108-132 the php version you use and change the date for eos (add few years, for example).

eos means End of Support and as @sharky said, this error occurs on a combination of outdated PHP and Joomla! versions. By changing eos date you simply allow to code continue to work without actual PHP/Joomla updating. For example I use Joomla 3.7.3 and PHP 5.6, but for today the latest versions are 3.9.14 and 7.4.1

This is more preferable way than accepted @omasan-esimaje 's answer, because in this case you still have the left vertical menu in admin panel. mod_quickicon is responsible for this menu, so disabling this plugin you disable this menu :)

Also in my case it was necessary to set public $error_reporting to development (ie public $error_reporting = 'development') in configuration.php, instead of maximum, in order to see the error.

In case, if you want to disable the plugin (according to @omasan-esimaje 's answer):

The easiest way to open DB is to download Adminer (Database management in a single PHP file) and put it next to configuration.php file, then open yoursite.com/adminer-x.y-z.php where x.y-z is the version of Adminer.

Necessary credentials for connection to DB you can find also in configuration.php and they look like:

public $host = 'localhost';
public $user = 'juser';
public $password = 'jpass';
public $db = 'jdb';

For security reason remove Adminer once you disable the plugin.

|improve this answer|||||
2

@Sharky gave a valid point that helped me solve the same problem. However, I would like to provide an alternative to help others who found it difficult to resolve this issue too. Rather than commenting out the line of code and breaking something else by accident,

if you have access to the database via whatever means, you can disable mod_quickicon by changing the enabled field bit from 1 to 0.

As in the image below;

Sample record

This record can be found in extensions table.

Note: Your extensions table may have a 'prefix'_extensions

|improve this answer|||||
  • Thank you for contributing. In the future, please avoid using the quoteblock formatting as a highlighter. It is meant to be used to mark quoted text from some other source. Often it is used to signify error messages but is also appropriately used to cite documentation. If you wanted to quote a source, you could copy-paste the foreign text and include a link in your answer to the source. For example: joomlashack.com/blog/tutorials/disable-joomla-plugin – mickmackusa Dec 12 '19 at 8:59
  • Thank you for the feedback. Will do so next time @mickmackusa – Omasan Esimaje Dec 12 '19 at 11:19
1

This is a known issue that occurs on a combination of outdated PHP and Joomla! versions. Measures have been taken to avoid this in the future and a fix will be available in 3.9.14.

It is recommended to keep PHP, Joomla!, its extensions and generally any software running on your server up-to-date. If you have no intention of doing that, your only other option is to disable Quick Icon - PHP Version Check plugin.

|improve this answer|||||
  • How would I disable this without being able to get into the Joomla backend? Is there some code I can insert somewhere in one of the .php files? – Dave_M Dec 9 '19 at 22:47
  • Normally the error should appear only after logging in and only on control panel. Other pages should be usable normally. But if you can't even login, comment out the line of code specified in the error message to make the error go away for now. – Sharky Dec 10 '19 at 6:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.