5

The frontend icon on the language switch module is really annoying. How could I disable the frontend editing for a specific module?

EDIT: I do need this icon for all the other modules, it just that this icon position position is straight on the language switcher...

  • Have you thought of user access levels? – Zemplate Jul 8 '14 at 0:39
5

You could assign an additional css class to the module, and then in your stylesheet, set display:none.

UPDATE

The following for example hides the action buttons for the module with ID=1.

a[href*="id=1"].btn.jmodedit {
    display:none;
}
  • but that will hide the frontend icon and the module. I'm looking for a way to only disable the icon. – JinSnow Jul 10 '14 at 8:44
  • See the update which gives an example of what I was thinking. – Peter Wiseman Jul 18 '14 at 7:58
1

I don't believe you can disable this for specific modules, however you can do it globally:

In the Joomla backend, go to System >> Global Configuration, and you will see an option called Mouse-over edit icons for, which you can simply set to none.

  • but that will apply to all modules... – JinSnow Jul 10 '14 at 8:29
  • 1
    I know, this is what I mentioned in my answer ;) @FFrewin's answer in which case might be more appropriate – Lodder Jul 10 '14 at 8:31
1

module manager > module > permissions > choose the group you want to allow/disallow front-end editing of module (or edit/edit state) > change to denied

Should do the trick.

  • yes but I'm registered as a "super user" so logically it shouldn't work – JinSnow Jul 8 '14 at 15:59
  • I'm not sure I understand, if you simply want to remove the editing icon for this module then the method I mentioned above should work. You can change the access control levels for each user group even super users. Let me know If I am way off and I'll try help! – jonboy Jul 8 '14 at 18:58
  • when I set all the super user parameters to my "switch langage" module to "denied" it change nothing: I can still front end edit this module. That's weird... – JinSnow Jul 10 '14 at 8:33
  • Try create a new user group and see if the changes take effect. Also, take a look at Advanced Module Manager (nonumber.nl/extensions/advancedmodulemanager), you can set all sorts of custom permissions here which may help you work around your issue. – jonboy Jul 10 '14 at 10:35
1

You can use the module permissions and restrict what usergroups will have edit access to that module, but keep in mind that this will affect also the backend edit permissions. Similar topic here: Hide Edit Module option in front-end for admin users

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.