0

Trying to update PHP from 7.1.27 to 7.3.3 and can't seem to. Set error reporting to max and after awhile of loading these are the errors I get on top of a white screen (admin also gone)

Warning: mysqli_errno() expects parameter 1 to be mysqli, bool given in [host]/libraries/joomla/database/driver/mysqli.php on line 992

Warning: mysqli_error() expects parameter 1 to be mysqli, bool given in [host]/libraries/joomla/database/driver/mysqli.php on line 1004

Error: Call to a member function getActive() on null:

It does the same on 7.2 update. I've contacted the host to see if it's related to the core or their set up and they tell me it has to be a third party extension, but I cannot find any reference to or clue to lead me to which extension is causing problems. I have another site that is pretty much running the same stuff and it updated just fine.

Checking every log I can think of and cleaning up the deprecated messages nothing helps. The first 2 warnings appear over and over in the error logs. Searches are turning up absolutely nothing.

Has anyone ever ran across this or know what may be causing it?

EDIT

Don't have many extensions installed, but disabled them one by one and no luck. Managed to get a new error by turning off max reporting and checking host error logs.

[Sun Jun 02 12:33:57 2019] [warn] [client [ipredacted]] mod_fcgid: error reading data from FastCGI server [Sun Jun 02 12:33:57 2019] [error] [client [ipredacted]] Premature end of script headers: index.php

EDIT 2

Don't know if anyone can tell anything from the site itself, but the previous url has changed, new url is

https://cdxx-us.com

This can be edited out if desired. Host is CloudAccess.

EDIT 3

Tried again 6/14/19

Warning: mysqli_errno() expects parameter 1 to be mysqli, bool given in [host]/libraries/joomla/database/driver/mysqli.php on line 992

Warning: mysqli_error() expects parameter 1 to be mysqli, bool given in [host]/libraries/joomla/database/driver/mysqli.php on line 1004 Error: Call to a member function getActive() on null: Warning: session_write_close(): Failed to write session data using user defined save handler. (session.save_path: /tmp) in [host]/libraries/joomla/session/handler/native.php on line 194

J!3.9.6 -> updated 3.9.8

  • getActive() may be something to do with the Menu Model. Please trying posting an issue on the Joomla Github Issue Tracker as it could potentially be a core related bug with Joomla on PHP 7.3 – Lodder Jun 1 at 21:30
  • I'll have to sign up over there. Only pause I have is I seem to be the only one with the issue and I have another website that updated fine, so super confused as I didn't do anything different there, and certainly never messed with any mysqli settings. The main differences are custom built modules and they show no errors. Tried searching the code for getActive() but couldn't find it. – Mythic Jun 2 at 4:43
  • Github doesn't support my browsers, sorry github some of us are poor. – Mythic Jun 2 at 6:36
  • Erm what browser are you using? – Lodder Jun 2 at 8:19
  • 2
    Have you compared the installed PHP extensions between your PHP 7.1 environments and your 7.2 & 7.3 environments? My own 7.2 environment is working fine with mysqli, mysqlnd, pdo and pdo_mysql checked. – Irata Jun 2 at 9:48
0

In the Global Configuration, you could try setting the Database Type to MySQL (PDO) at least as a temporary fault finding measure.

Check in cPanel (or similar) that the required PHP extensions are being loaded. For example, Joomla runs fine for me with the following extensions loaded on PHP 7.2:

PHP 7.2 Extensions

  • I don't have any of that, just an update option. I recommend backing up before anyone tries this. Couldn't edit config file, had to have host edit it for me, then site just said Error with message on backend about couldn't find library. All is well now, waiting to hear back from host, they keep telling me it's an extension, but i don't think it is. On the up side, when i got the error after switching to mysqlpdo and updating to 7.3.3 it was given through my template, had the site logo image and the same screen as 404 almost. Would that happen if it was an extension? – Mythic Jun 3 at 14:45
  • 1
    Seeing the site logo is progress from a white screen. If you now have access to the back end, updating all Joomla extensions and Joomla to the latest versions may help. It's difficult to provide accurate advice unless you can tell us the latest error message (if there is one). – Neil Robertson Jun 4 at 0:35
  • I keep everything up to date, i checked again anyway and everything is up to date. I agree progress, i would think if it was an extension i would have gotten the same white screen, but i'm no expert. Host said same thing. It's almost like i'm talking to ai or someone who doesn't understand english. Pretty clear what i'm trying to do and get these short nonsense answers, i don't think they've even looked at anything on their end going by their responses. Kind of like you'll be alright, now close the ticket. – Mythic Jun 4 at 7:40
0

After letting this go for awhile and then eventually opening another ticket after J! started giving me the warning this was finally resolved. It was kicked to the admin and then fixed within a couple of days.

There will be no solution as i'm told it was not on my end. Thanks to those who tried to help and cloudaccess admins.

If anything this teaches us if we're sure we've tried everything to keep asking the host to check. This question can be deleted if desired.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.