My Joomla is 3.9.4. When I tried to make some global configuration change in the backend, I got this error:

Could not write to the configuration file.

I looked at the file system, configuration.php has the right owner and is set to 0644, and I can make changes to it via FTP.

I then tried setting the permission to 0777, it is writable; then I tried 0666 and 0664 and it is also good.

Only when I set it to 0644 do I get the above error. I've never encountered this kind of problem before. I suspect it is something wrong with my server(I host the website on a VPS on linode), but I couldn't figure out.

What could possibly be wrong?

UPDATE I found some more clues. This website was duplicated from another server where the website ran well. When I look both site's FPA, I found that on the problematic server, the permission section is like enter image description here

While on the other server, it is enter image description here

I don't understand how come one is writable whereas the other is not while both permissions are 0755.

1 Answer 1


The answer is here, need to set php running mode to FastCGI: https://docs.joomla.org/Why_can%27t_you_install_any_extensions%3F#File_ownership_advice_from_ianmac

  • 1
    please accept your answer so that the system stops bumping it. Oct 9, 2019 at 3:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.