0

I've updated to PHP 7.2.17 through my host's cpanel, but I'm still getting a message in the Joomla backend that my PHP version is not updated.

Error

We have detected that your server is using PHP 7.0.31 which is obsolete and no longer receives official security updates by its developers. The Joomla! Project recommends upgrading your site to PHP 7.1 or later which will receive security updates at least until 2019-12-01. Please ask your host to make PHP 7.1 or a later version the default version for your site. If your host is already PHP 7.1 ready please enable PHP 7.1 on your site's root and 'administrator' directories – typically you can do this yourself through a tool in your hosting control panel, but it's best to ask your host if you are unsure.

Any help to reflect correct PHP version in Joomla would be appreciated.

  • Did you select the new PHP version through the PHP Selector or the Multi-PHP options in cPanel? Normally only one or the other will have the effect of changing the PHP you are using. – Irata May 2 at 9:31
1

Look in your .htaccess file to see what version of PHP was added via cPanel. Depending on the host it is usually reflected in either .htaccess or a php.ini file in the root of your directory. Just modify that file to the version you want and it should fix things.

Also if you have a server running SuperCacher or an equivalent file caching module, clear that cache and it may resolve the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.