0

I'm adding a new fieldset with custom params to my template:

<config>
    <fields name="params">
        <fieldset name="advanced" addfieldpath="/templates/mytemp/fields">
            ...     
        </fieldset>

        <fieldset name="custom">
            ...

The name of that fieldset gets used for the Template-Tab as following:

COM_TEMPLATES_CUSTOM_FIELDSET_LABEL

In which language file (that needs to be installed with the template) can i insert that language constant?

de-DE.tpl_mytemp.ini and de-DE.tpl_mytemp.sys.ini is not working.

  • Your question appears to unresolved/abandoned and therefore "bumped" by the system. Have you managed to resolve your issue? If Sharky's answer did the trick you can award the green tick or post your own answer. All questions should progress to a system-recognized resolution. Please let us know if there is more that we can help you with. – mickmackusa May 18 at 9:17
0

First I suggest that you do not use language strings containing prefixes of other extensions. You can use your own language strings by adding label attribute to the fieldset:

<fieldset name="custom" label="TPL_MYTEMP_CUSTOM_FIELDSET_LABEL">

The file for template configuration strings is de-DE.tpl_mytemp.ini. Depending on your template setup it should be installed either in language/de-DE or templates/mytemp/language/de-DE. If the file is not loaded, make sure mytemp matches the value of <name> element in templateDetails.xml file. Neither should have tpl_ prefix, apparently. When language files are loaded tpl_ prefix is added automatically so in case you do have it in your template's name, the resulting file would end up being de-DE.tpl_tpl_mytemp.ini.

To further debug language issues enable Debug Language in Global Configuration. With this you'll see which language files are being loaded, which files are missing and if there's any errors.

  • All was done that way. The COM_TEMPLATES_CUSTOM_FIELDSET_LABEL gets displayed in the tab without me doing anything. Seams like this <fieldset name="custom">in the template XML gets parsed, but i don't understand why it's not taking my template name mytemp and thus my language constant. – Mike Apr 18 at 15:29
  • It's not supposed to. If no label is present, it builds this: COM_TEMPLATES_' . $name . '_FIELDSET_LABEL, where $name is fieldset name. – Sharky Apr 23 at 6:01
  • Also make sure that your language file has been formatted correctly. If you forget a quote somewhere, or an equals = symbol, then Joomla will only show the language tag (and not the values from the language file). – pe7er Apr 24 at 15:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.