0

I have an installation where the article options are wonky. Global and article seems to be working, but on the menu (blog) the "Use Global" options is not available (as it is with a fresh install or all my other sites...).

Also, when the menu options are set to "Use article" they are used correctly when the blog layout is active, but when I click on a "Read more" for one of the blog items, that view does not adhere to the article settings.

Any clues to where I should be looking next is most appreciated.

1

The menu item options are configured using xml files in the front-end views of your components.

Could you compare the configuration file for the "Category Blog" view with one from a working website? /components/com_content/views/category/tmpl/blog.xml It should have a useglobal="true" parameter for all the fields that have the "Use Global" option.

Does your template uses a template override for the current template, that has an override of that configuration file? Check if you have a file called /templates/{your_template_name}/html/com_content/category/blog.xml It is probably missing the useglobal="true" in all its form fields. If so, disable the override by renaming it to blog-old.xml and check your menu options again.

  • Thanks! That was very valuable information. However, it did not solve my problem. The troublesome site's tmpl/blog.xml has the 'useglobal="true"', still that "Use Global" is not available. I could add another explicit option by adding an option value, so it seems that this is the blog.xml that is used (and it's the only one existing too). So what's next? Are there some database values involved here? – thoni56 Apr 14 at 8:25
  • Which Joomla version are you using? Could you test it with the default Joomla template Protostar? – pe7er Apr 14 at 11:57
  • I'm on the latest available (3.9.5) and on the site I get the same strange behaviour with protostar (and with the old hathor backend template, since that's where the fields are shown). So it does not look like it is in the templating. – thoni56 Apr 14 at 13:41
  • Actually, it looks like it's the global options that are not fetched correctly. An article option that shows "Use global (Hide)" doesn't actually hide the item unless I explicitly set it to "Hide". – thoni56 Apr 14 at 13:43
0

Turned out that it was a very old library (Expose Template Framework, from 2013 and Joomla 2.5) that was laying around and interfered with global settings.

Removed it and the site is back to normal.

Moral: always trackdown and remove old stuff from your CMS!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.