0

I have joomla 3.x site (mydomain.com).

www.mydomain.com and www.mydomain.com/index.php produce

404 error

However, www.mydomain.com/index.php/welcomepage works fine and opens my welcomepage.

I can't navigate in mydomain without problems.

How can I force joomla to correct index.php?

  • What settings do you have in the Global Configuration for SEF URL's and Use URL Rewriting? And are you using the standard .htaccess(renamed from htaccess.txt) file that comes with Joomla or not. If you do a Google search for 'joomla exclude the index.php file' you will see a number of items explaining how to set up your site to not display the index.php in the URL which is good SEO. – Irata Apr 12 at 0:00
  • Thanks for your comment. I had the idea to try to change the start page of my Joomla site, and found that I had to click the star icon of the page I wanted, in the "main menu", in my admin panel. Doing that, I realized that no page had the star icon set (?). I just clicked the star icon of my "welcomepage" and everything works fine again. I do not understand how or why this setting disappeared, but ok ! Thanks any way (I will follow your recommendation and try to do the modification to not display the index.php in the URL) – Jos Remacle Apr 18 at 9:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.