0

I've updated to Joomla 3.9.3 and now I get this error 500 Unknown column 'a.note' in 'field list', by opening the articles pages. I've tried to fix the database with the repair function, but this wasn't possible too, cause I get another error.

1709 Index column size too large

To solve this I tried the repair function from phpMyAdmin, but I'm not so familiar with this. My first try there did not work too.

Looking at the Databas in Joomla, I get the following errors:Table 'DB1805098.#__privacy_consents' doesn't exist Table 'DB1805098.#__action_logs' doesn't exist Table 'DB1805098.#__privacy_requests' doesn't exist

Any other hint how to fix this? Everything else seems to work finde in Joomla.

  • Can you show us what you get from echo $query->dump();? Perhaps #_ isn't being appropriately replaced. Perhaps there has been an adjustment to the table that is aliased as a. Can you let us know what the a table schema looks like? Are there any extensions or have you done any development that may be impacting things? – mickmackusa Mar 11 at 23:22
  • Index column size is too large error most probably is coming from not optimal db collation setting. This answer is on Laravel, but it can help you with your problem too: stackoverflow.com/questions/42043205/… – Zollie Mar 12 at 6:13
  • Thanks for your hints. I'm sorry, but I don't have a clue about database debugging. So, I will try to work through. I have no idea where to place the echo command to get the current $query by calling the article page. I've look for the a table in my database, but couldn't find it yet. I understand the Index column size is too large failure, but without knowing which column causes this, I'm not able to fix it. – Patrick Münster Mar 12 at 15:13
0

I found a solution that worked for me and where I had not to dig into the code and database.

  1. Setup a new local Sytem of Joomla with the last running Joomla version (which was 3.6.1 in my case)
  2. Exported the database from the live system and imported it to my local Joomla
  3. Repaired all database failures with the Joomla autorepair function. On my local system it worked fine.
  4. Updated Joomla to the live (server) version.
  5. Copied the whole filesystem via FTP from my server and overwrite the local system.
  6. Checked for any failures
  7. Exported the database and imported it on the live system again.

All problems solved!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.