Is there a way to make all my categories to be "noindex"? (Plugin or even better default joomla way)

Right now crawlers find the category URLs and thus create duplicate content on search engines.

Would be great to have one central config for all categories.

2 Answers 2


Having the same problem I went down to the database.

with this SQL you can update ALL categories to noindex and to nofollow for search engines (google, bing, yandex)

UPDATE `jos_categories` SET `metadata`='{"author":"","robots":"noindex, nofollow"}' WHERE `extension`='com_content'

you need to find out your table prefix, in the above example jos_ is the default prefix of joomla. If your table prefix is xzhw_ of course your SQL would be

UPDATE `xzhw_categories` SET `metadata`='{"author":"","robots":"noindex, nofollow"}' WHERE `extension`='com_content'

be careful

if you use categories for displaying other content in e.g. a category blog, DO NOT USE THE SQL. Instead you should eiher select your categories in the WHERE clause or even better you go manually through the categories in the backend of joomla and you edit under Publish-tab the Robots to noindex, nofollow

  • thank you, tested it with phpmyadmin. worked great and reduces a lot of manual work if you have a bunch of categories!
    – cilap
    Apr 6, 2019 at 13:52

You can walk through all categories, and in the Publishing tab, set the Robots option to No Index.

  • is there a default setting on joomla to make this as a default for all categories?
    – cilap
    Feb 24, 2019 at 17:13
  • @cilap In Joomla Global Configuration in the Site tab, set the Robots option to No Index, but this will affect all Joomla content, not only the categories. You can also try the use of robots.txt. See my answer to this question.
    – n.h.
    Feb 24, 2019 at 17:29
  • sadly the global setting will not help in my case since all of joomla articles would also go to noindex.
    – cilap
    Feb 25, 2019 at 7:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.