This is the site I'm talking about. If you click any menu item, you reach the correct page, but the page shows up garbled and the page URL is much longer than it should be, including categories names that the page does not even belong to.

However if I login into the backend and, while I'm logged in, I reload the main front page, then the menu links change (they become the normal "alias" specified in the menu item options) and the respective pages load correctly.

As soon as I logout from the backend and reload the front page, the links become incorrect again and the pages become garbled again, just as you can see.

I don't know what to google for. Joomla! is updated to the latest version, it has SEF URLs active and SEF URLs rewriting active, along with the provided .htaccess file and mod_rewrite enabled (but when the links are incorrect, they even include index.php)

I've already tried flushing all caches (expired and not expired) and unlocked everything in the global check-in, to no avail.

Any clue?

1 Answer 1


It's probably best to run a backup before making any changes.


To narrow down the problem, try disabling URL Rewriting and SEF and renaming .htaccess to .htaccess.old. If this helps, try re-enabling the default .htaccess file, then SEF and then URL Rewriting, clearing the cache and checking the website after each step.

Clear Cache

Clear the Joomla cache to ensure you are looking at the latest version of the website. Also clear any server side or other cache such as SiteGround Dynamic Cache or LiteSpeed cache if these are enabled.

Turn off caching

The different cachings of the site can cause conflicts. In order to check whether the problem comes from that, turn them off (all of them if needed).

Update Everything

Try updating Joomla and all third party extensions to the latest versions as a general troubleshooting step.

Third Party Extensions

If there is still no solution, try temporarily disabling all third party extensions. If that helps, re-enable third party extensions one by one to see if the problem is associated with a particular third party extension.


Try creating a fresh install of Joomla in a sub-directory or similar to see if there is a problem with the hosting. Alternatively, backup the website and install to an alternative host to see if this makes any difference. You can create a free hosting account with CloudAccess for testing.

Reinstall Joomla Core Files

Lastly, try the "Reinstall Joomla core files" option in Joomla Update.

  • Disabled all SEF, cleared all caches, updated everything (it was already up to date), disabled the only 3rd party extension I had (the template) and reverted it to the Joomla! bundled beez3 and reinstalled Joomla! core files. I host the site myself on a dedicated server. The problem is still there. Feb 3, 2019 at 9:45
  • Did you try reverting to the standard .htaccess file? Feb 3, 2019 at 9:47
  • I've never modified the .htaccess file from the bundled one, just renamed it from htaccess.txt back and forth. Feb 3, 2019 at 9:55
  • It might be an issue with the hosting environment. I've probably reached the limit of what I can suggest based on the information provided. Everyone else should feel free to add additional suggestions. Feb 3, 2019 at 12:32
  • 1
    @LucioCrusca - I got you. At the moment your site first create sef urls then immediately create the same without sef. So the routing of the site is screwed. I do not see at the moment how and why, but you have to turn off really all cache of the site, not only clean them. It looks like that it loads the site from some cache from somewhere then loads the same content again without sef.
    – Zollie
    Feb 4, 2019 at 11:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.