0

I am having trouble with custom 404 page,

So I have been trying to get the custom 404 page to work but I have problem making it work right. All the methods that are described everywhere :

  1. make custom 404 page,
  2. add it to menu
  3. copy error.php from system and set it up.

Does NOT work as it should, it returns code 200 instead of 404 with the page (as it found the page) which is bad for SEO as google thinks that any possible page of the website is good (code 200).

I purchased the plugin called Rapi custom 404 (link) however it doesn't work.

Tech support from Rapi provided me with new custom error.php page containing:

<?php
defined ('_JEXEC') or die();

$plugin = JPluginHelper::getPlugin('system', 'rapi_custom_404_page');
$params = new JRegistry($plugin->params);
$page_title = $params->get('error_title', "404 - Page Not Found");
$heading_text = $params->get('heading_text', "OOPS! Page Not Found");
$description_text = $params->get('description_text', "The page you are looking for doesn't exist");
$home_button_text = $params->get('home_button_text', "Go Home");
$theme = $params->get('theme', '1');
include "plugins/system/rapi_custom_404_page/themes/theme{$theme}.php"; 
?>

And it still doesn't work, now I think the error comes from the .htaccess file. I have been toying with it, and at the moment I am having this:

##
# @package    Joomla
# @copyright  Copyright (C) 2005 - 2018 Open Source Matters. All rights reserved.
# @license    GNU General Public License version 2 or later; see LICENSE.txt
##

##
# READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE!
#
# The line 'Options +FollowSymLinks' may cause problems with some server configurations.
# It is required for the use of mod_rewrite, but it may have already been set by your
# server administrator in a way that disallows changing it in this .htaccess file.
# If using it causes your site to produce an error, comment it out (add # to the
# beginning of the line), reload your site in your browser and test your sef urls. If
# they work, then it has been set by your server administrator and you do not need to
# set it here.
##

## No directory listings
<IfModule autoindex>
  IndexIgnore *
</IfModule>

## Can be commented out if causes errors, see notes above.
Options +FollowSymlinks
Options -Indexes

## Mod_rewrite in use.

RewriteEngine On
ErrorDocument 404 /templates/e4jdrivers/error.php

## Begin - Rewrite rules to block out some common exploits.
# If you experience problems on your site then comment out the operations listed
# below by adding a # to the beginning of the line.
# This attempts to block the most common type of exploit `attempts` on Joomla!
#
# Block any script trying to base64_encode data within the URL.
RewriteCond %{QUERY_STRING} base64_encode[^(]*\([^)]*\) [OR]
# Block any script that includes a <script> tag in URL.
RewriteCond %{QUERY_STRING} (<|%3C)([^s]*s)+cript.*(>|%3E) [NC,OR]
# Block any script trying to set a PHP GLOBALS variable via URL.
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
# Block any script trying to modify a _REQUEST variable via URL.
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
# Return 403 Forbidden header and show the content of the root home page
RewriteRule .* index.php [F]
#
## End - Rewrite rules to block out some common exploits.

## Begin - Custom redirects
#
# If you need to redirect some pages, or set a canonical non-www to
# www redirect (or vice versa), place that code here. Ensure those
# redirects use the correct RewriteRule syntax and the [R=301,L] flags.
#
## End - Custom redirects

##
# Uncomment the following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla! Directory (just / for root).
##

# RewriteBase /

## Begin - Joomla! core SEF Section.
#
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
#
# If the requested path and file is not /index.php and the request
# has not already been internally rewritten to the index.php script
RewriteCond %{REQUEST_URI} !^/index\.php
# and the requested path and file doesn't directly match a physical file
RewriteCond %{REQUEST_FILENAME} !-f
# and the requested path and file doesn't directly match a physical folder
RewriteCond %{REQUEST_FILENAME} !-d
# internally rewrite the request to the index.php script
RewriteRule .* index.php [L]
#
## End - Joomla! core SEF Section.

Is there anyone that could help me fix my .htaccess page to get it to work?

0

You should be able to adjust the error.php file to set the header either with the

  1. Joomla way:

    $app = JFactory::getApplication();
    
    $app->setHeader('HTTP/1.1', '404 Not Found',true);  
    
    $app->sendHeaders();
    
  2. PHP way

    header('HTTP/1.1 404 Not Found', true, 404);    
    

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.