I upgraded my Joomla website and I am getting the folloing error:

I added following code:

if(!class_exists('JToolbarHelper')) {
    require_once JPATH_ADMINISTRATOR . '/includes/toolbar.php';
}

to this file:

/sitefolder/administrator/includes/helper.php

Nothing happened and site broke completely.

  • 1
    Please if you could add an additional info about exactly which Joomla version you've updated to which version of Joomla. On what PHP version the site is running? With more info you might get faster help from others. Thanks. – Zollie Nov 19 at 17:25
  • 1
    And from the error message, it would also be helpful to know which component is not finding the 'JToolbarHelper' Class – Zollie Nov 19 at 18:57
  • I am getting the same issue after attempting to upgrade. The upgrade failed. I followed the same and edited the helper.php file and get "error" trying to load the admin page. I removed the edit I tried modifying the helper.php file but did not help – Jsdao Nov 19 at 23:05
  • @JohnSdao - Could you please set the error reporting to maximum or developer level to see the whole stack of this error in your sites. In your joomlasite/configuration.php file set the following and save it: public $error_reporting = 'maximum'; --- Then most probably you will see a more complete error message about this problem. Paste the full error message then here. This way we could probably help you. – Zollie Nov 20 at 13:21
  • Or set in configuration.php -> public $error_reporting = 'development'; – Zollie Nov 20 at 13:32

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.