0

So well, I have an issue with an artisteer theme, or so I thought. The problem lies within Joomla because using other themes results in the same outcome. Please look at TKMS.si, so you'll know what I mean.

I inspected the problem and noticed there are problems with the classes added to the posts.

<div class="item column-1">[...]</div>

This is the wrapper div of the second post. I removed column-1 from the class:

<div class="item">[...]</div>

And now it works flawlessly, but how can I change it on the server so it stays like this? (I was only using Chromiums Inspect Element)

Thanks in advance.

EDIT: I found the article manager options and there I found Blog /featured layouts and I changed the number of leading elements and links to 5 and others I changed to 0. Still there is no change. What to do?

  • This is something that's generated in the functions.php or the index.php file within your template folder. I would strongly recommend using a non-artisteer template as they are simply (excuse my french, but...) crap – Lodder Jun 19 '14 at 13:21
  • Yeah I know, but I have been told that I must use this. It's not the themes fault I am sure, because other themes have the same problem. – Tristan Šneider Jun 19 '14 at 13:24
  • I did find what I've been looking for. The problem was in the menu entry where the numbers I mentioned in my EDIT are also written. I left the fields blank and the global settings applied. – Tristan Šneider Jun 19 '14 at 13:37
  • 2
    Default Joomla themes do not use column-1 anywhere so this must be a default class that Artisteer uses – Lodder Jun 19 '14 at 14:37
  • Open the menu item and look at the layout settings there as well for leading articles and columns. – YellowWebMonkey Jun 19 '14 at 17:12
1

When you changed the article options, you only changed the global defaults

Open up your menu manager Edit the menu ITEM Go into (blog) layout settings and you will find the options for Intro Articles, columns etc

Make the change here and you should now see results. Ironically if you leave these fields blank global defaults are used, but I think by default they are NOT blank and pull in the global default settings.. hence the global configuration will not work.. which is just damned annoying!

No need to make any code changes for this fix at all

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.