5

I have install SigPlus 1.5.0.262 on Joomla! 3.7.5. I am just trying to get the watermark to work. I cannot seem to get it to appear. I think my issue is just where I am placing my image. According to the advanced guide..

A watermark is a PNG file with transparency channel (i.e. the image has RGBA color scheme) placed either in the same folder where the images to be shown are (specified within the plug-in activation start and end tags), or in the image base folder (specified in the administration back-end).

I interpret the "base folder" as /images.

I have tried both of those locations and I still cannot get it to show up. Its simple small png.

Under the advanced settings for the module I have changed the settings for watermark

Advanced watermark settings

Things beyond above I tried:

  • Using a bad file name on purpose. Does not trigger an error state that I could find.
  • Nothing in any logs I could find e.g. administrator\logs\error.php
  • If you are using relative paths, which other paths have you tried? Normally, when a program tries to access an image that doesn't exist in the directory where it is told to look, a clue is provided in the form of an error. I've not yet used SigPlus, but I would hope that there would be some feedback in the form of server-side or client-side errors. Please try to discover some new details to share with us. – mickmackusa Oct 7 '18 at 20:09
  • 1
    I have not tried any paths but tried puttinh the image into the locations i think it expects it. There are not any errors to be seen. Perhaps it is finding it but it does not like the image itself. I will see what i can turn up – Matt Oct 7 '18 at 20:15
4

I thought I had already done this before I posted but I tried again and got positive results

So after looking at a post about a supposed bug with an earlier version of the plugin there was a couple of clues as to a solution from the developer

The module, however, does not have an image base folder, which means that the only place you could put watermark.png in the current implementation of the sigplus module is the image gallery folder.

and

you should create a subfolder watermark inside the image gallery folder, and place watermark.png within that subfolder.

I created a folder called watermark in the root of the gallery folder (identified as image source in the module properties) and placed the watermark.png inside that folder.

Changed the Advanced Settings > Filename for watermark to "watermark/watermark.png"

After changes were saved and associated page refreshed I was able to see the watermark.

  • 1
    Great self-solve. Thanks for posting a clear, informative answer for future researchers. – mickmackusa Oct 8 '18 at 2:12
  • 1
    Well done for figuring it out and providing lots of info in both your question and answer – Lodder Oct 8 '18 at 7:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.