-1

This question was originally asked on StackExchange, and it was recommended by @mickmackusa that I ask it here.

Background

We recently changed over from one server to a brand new one.

Old server: PHP 5.7, Joomla 2.x, MySQL 5.6.x

New Server: PHP 7.0, Joomla 3.x, MariaDB 10.x.

The OSE Plugin is the different, but given that it is affecting rows outside of OSE (They seem to be defunct now, as we are not getting any reply from their support staff).

On both servers, this glitch can be replicated, but not 100% of the time.

The Issue

Near as we can tell, any value that is entered into the table that contains "select", "selected", or any other variation of the word results in a generic 500 error. This happens when changing an article that includes the word, when changing an email template in the OSE control panel (e.g. "membership selected:"), or when trying to change those rows manually through a PHPMyAdmin installed manually.

Curiously, when logging into the PHPMyAdmin through the installed cPanel, we can change those values there. This obviously isn't a long term solution as we can't give our writers cPanel / PHPMyAdmin access, but I mention it to help understand the whole picture.

What we tried

Error Logs - No Error logs (that we can find) show anything related to this issue.

Permissions - Permissions don't seem to affect this issue, as we can make changes to any value, as long as they don't include "select" or any variation of that name.

The Goal

What I want to understand is why the cPanel PHPMyAdmin can make these changes, but not the manually installed one, or Joomla / OSE.

0

Started to write a comment, but it will become to long, so writing here:

From your given info, I tend to think this isn't something in Joomla. Most likely it is something with your server environment, which you need to ask support from your hosting provider. Could be a firewall or something, although the fact you get a 500 error.

To sum up a few things:

Whenever you save data that includes any work that contains "select" you get a 500 error? And this is also true when you do it through a second instance of phpMyAdmin? And it happens in both your servers?

Getting the same issue from both your old and new Joomla sites and also from another application think phpMyAdmin means this isn't something inside Joomla.

Is the same hosting provider for both the servers?

Have you tried this on a local installation of the site, or other hosting providers? If not, just do it to test and confirm the case.

If you want to use an .htaccess in the local instance (e.g. for SEF URLs), use just the core one - with the absolute minimum settings. If you get the same issues, then start disabling plugins as a first move and report back here.

  • It is hosted on local physical servers, we checked the firewalls multiple times. There are two versions of PHPMyAdmin installed. One that is installed alongside cPanel, and one that we installed separately. The one in cPanel works fine, but the issue occurs in the manually installed one, as well as Joomla, OSE, and any other front-end we can find. And yes, it is specifically when using "select" at all. – ZLHysong Sep 6 '18 at 17:29
  • Do a test to install the site on another environment - e.g. download MAMP and run Joomla from there to see if you still get the issue. However, from what we know so far, I am afraid you won't be able to get an answer to solve your issues in this site. Actually this doesn't seem to be Joomla related. You need to investigate your servers. @ZLHysong – FFrewin Sep 6 '18 at 19:13
  • I understand. I'll try that either this weekend or early next week and get back to you. In the meantime, if it's not Joomla-Specific, we can mark this as off-topic and I'll share my results in the other topic on SO. – ZLHysong Sep 7 '18 at 15:43

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.