Joomla 3.8.11

I have a simple article with access level set to Registered. A mod_login module is assigned to the menu item for the article.

On accessing the menu item, the login module is displayed as expected. However, when credentials are entered I get a 404 page 'Conponent not found. The requested resource was not found'.

If the article access level is set to Public, the page is displayed fine.

I'm positive that this used to work, but cannot understand what the issue is now.

Thanks for any pointers.

  • Can you post a link to the page with this issue?
    – FFrewin
    Aug 31, 2018 at 10:22

2 Answers 2


Thanks FFrewin. I had been through most of these with no joy.

What I did in the end was to dump out the whole of the error object on the error page (print_r($this->error)).

This pointed to the com_users component as being the source of the problem. On further investigation this entire folder was missing (inadvertently moved by someone)! Restoring that solved the issue.

  • Hi, glad you solved the issue. While writing the troubleshooting steps, I thought that com_users could be missing as a possibility - but somehow I forgot it to add in the steps in the end. I will include it in the troubleshooting steps, so the list will become more concise, if someone reaches here in the future to be able to find it easier in 1 place.
    – FFrewin
    Aug 31, 2018 at 11:02

Following some troubleshooting steps you can take, in order to find what is likely the cause of the issue.

  1. Review what's the return URL after the login. Is it the same with the URL that you were sitting before the login? Also you can disable SEF URLs if they are On, and see what's the actual non-SEF URL. See if its option value is not com_content. Update your question and report back your before and return URLs.

  2. If you are using a mod_login to login to the page, then 1st thing to check is in the module settings - the login redirect page that is assigned to the module.

  3. Also try to see what happens even when you set the article as public and can see its content, but would try to use the login module to login.

  4. When logged-in in the front-end, and you got that component not found error, leave that error page and go to the home page to have your site loaded as usual. Then use the menu-item to reach at that page with that article and see if it's loading. Or - remember the exact URL of that article and try to load it directly.

  5. Review your plugins and see if there is any that could be involved in the login workflow. You can try disabling some of them.

  6. Make sure your Joomla installation is not corrupted, like having missing components. As proved by the OP in his answer, in his case it was the com_users component that was missing.

  7. The list can go on with further checks on your User -> Login menu items settings, your template overrides, or other extensions that could be involved in your login/redirect workflow. But check first all the above and report back if you have any new findings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.