enter image description here

I have exhausted all the options (to the best of my knowledge) and there are still 2 seconds of server waiting time.

I have upgraded to the latest version of Joomla, jch optimize pro, jotcache, gzip, etc.

We are using a VPS with decent configurations.

Any clues will be helpful to find out the root cause.

  • Enable debug, inspect profiling information and database queries. – Sharky Aug 10 at 5:20

Enabling server side caching can help.

For example, installing the free LiteSpeed Cache extension for Joomla 3.x on a suitably configured LiteSpeed server can dramatically reduce the time to first byte (shown in yellow below):

enter image description here

  • 1
    I would also note it's better to cache at server level, rather than CMS level – Lodder Aug 10 at 9:12
  • Can I install OpenLiteSpeed's cache module on my VPS which is using Apache server... please pardon my ignorance. – Topcafirms Kaushalya Aug 12 at 3:56
  • Litespeed Cache will only work with a suitably configured Litespeed server. There may be other server side caching options available. For example SiteGround offer "Dynamic Cache" on GrowBig shared hosting plans or better. It's probably best to check with your hosting provider what is possible. – Neil Robertson Aug 12 at 4:01

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.