3

I've posted this over on forum.joomla.org but don't know which user group is more active.

I am new to joomla but have extensive experience (10+ years) with other cms.

Client gave me a kickstart .jpa file to move their site to a new host server. The kickstart seemed to run fine but every page of admin has yellow warning box with "00000, ,". enter image description here

The front end of the site on the new host only says "Error" but with almost a whole screen of html before. I can see joomla code (ie <jdoc:include type="head" />) when I view frontend source.

I've tried turning on debugging in System > Global Configuration > System tab but there was no additional info.

Can anyone suggest somewhere to start looking?

Thanks Amanda

  • In host cpanel I rolled php back to 5.6 and at least it's showing the site front end. – Amanda Lutz Jul 9 '18 at 20:09
  • tail error_log? – Alexandros Jul 9 '18 at 21:16
2

00000 is an SQL error usually, and the fact that debug doesn't show anything further suggests that it's coming from outside of php land. I'm guessing that you're trying to use pdo, switch to mysqli and then it should work.

  • Yes, switching to mysqli (Global Configuration > Server > Database Type) removed the warning. I wonder why it wasn't set on the original site? Oh well. Thanks! – Amanda Lutz Jul 10 '18 at 15:09
  • @jamesgarrett Do you work at preflight? I am confused, there is another garrett at that agency in Melbourne. I wanted to ask you to fill out our 5-minute JoomlaDay survey: joomladay.org.au/program/have-your-say but I couldn't find a contact email for you. – mickmackusa Oct 21 '18 at 23:52
  • Indeed, I work at Preflight. – jamesgarrett Oct 23 '18 at 21:48
1

You are seeing the errorInfo data. The good news is that what is being displayed actually means NO errors.

When errorInfo serves up: array('00000', null, null) everything is functioning flawlessly ...or at least one of your queries ran flawlessly. You see, it may serve up the last successful query and not express a subsequent error.

Anyhow, you don't really want to see that mess so the solution should be to apply this setting to your pdo:

setAttribute( PDO::ATTR_ERRMODE, PDO::ERRMODE_EXCEPTION )

The easiest place to add this attribute is immediately after your connection (where ever you are doing that).

http://php.net/manual/en/pdo.setattribute.php

Here are a few relevant StackOverflow posts:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.