0

I have something strange going occurring on one of my sites and have no idea how to resolve it.

When searching for an article, clicking any article link in the search results leads to a 404 page for that article. I have disabled URL Rewriting but the problem still seems to exist. You can see the problem here -

Does any one happen to have experienced this in the past or know where I can start in trying to debug this? The site is huge so is pretty problematic anyway.

Any suggestions would be most welcome.

Update: Ok, so I have installed ACL manager and cleaned up the assets table (1000's of old articles transfered across by a previous developer) to no avail, I have also restored the .htaccess file to the Joomla default version but again it makes no difference. I have also disabled all Smart Search plugins, again to no avail. The only way i can get the links to work is by turning off URL rewriting and SEF URLS in global config. This is seriously baffling me?

The site content was copied across by another developer using SP Upgrade, hence (i'm guessing) why the assets table was in such a mess.

I'm seriously running out of ideas - the live site is at hrfuture (dot) net just for reference.

1

It appears to be your SEF URLs that are causing the issue. If I had to guess it is because your have Joomla running in a subfolder maybe? Turn off SEF URLs completely and clear your cache to see if the articles load. If they do the issue is in your .htaccess file.

In your .htaccess file look for the following line:

#RewriteBase /

Change it to:

RewriteBase /hrfuture

Enable your SEF friendly URLs again and you should be good to go.

  • This is actually a copy of the site that I am debugging, the live site is not on a subdomain. If I turn off URL rewriting there is no change, however if I turn off SEF Url's the pages load, albeit with 'dirty' urls. This is really baffling me. – Dtorr1981 May 12 '18 at 19:05
  • Yep. If the URLs are loading with SEF turned off the problem is the htaccess file. Try the change I suggested and turn them back on. – Terry Carter May 14 '18 at 4:05
  • On the livesite it would just be RewriteBase / – Terry Carter May 14 '18 at 4:05
  • Thanks Terry, no this does not work either. I think it is likely due to there not being a menu item for the categories, unfortunately there are ALOT of categories on this site so I am looking at creating one Top Level category and batch moving all the others under this, then creating a category blog page to the top level category as a hidden menu item. I will post back my findings. – Dtorr1981 May 14 '18 at 15:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.