2

I just migrated a Joomla site from live to localhost. Have the front end up and can access the backend without problem.

Front end wise none of the menu items work.

I have renamed the live site variable to point to http://localhost/domain. I also disabled SSL via config and disabled .htaccess files.

Permissions have been added for tmp and cache directories where required. Wondering what else I could be missing. Any ideas would be appreciated.

Wondering if this could be db or file related, relevant details below

public $live_site = 'http://localhost/Clients/domain';
public $log_path = 'F:\\ClientDevEnvs\\htdocs\\Clients\\domain\\logs';
public $tmp_path = 'F:\\ClientDevEnvs\\htdocs\\Clients\\domain\\tmp';
Have also edited httpd.conf file to enable and enabled htaccess mod_rewrite.
  • Did you checked cache,tmp folders are there at frontend ? – Sudhir Sapkal Apr 27 '18 at 9:48
  • Hi John, sure did. Initially I had to create the tmp and cache folders as these were missing but this was one of the first things I was doing as I couldn't login without them. – Nick Apr 27 '18 at 15:46
  • 1
    Please add the htacces file to your question and what happen if you click on a menu item (redirect / error). – Dennis Heiden May 3 '18 at 15:21
1

It's usually best to leave the $live_site parameter empty. In addition to removing/renaming your .htaccess file (which you already did), make sure your configuration.php file has the following settings:

public $live_site = '';
public $sef_rewrite = '0';

The second line will disable URL rewriting. You can also change this setting under "Configuration" from the Joomla back end.

On a side note, if you use Akeeba Backup and Kickstart to backup and restore your site, the tool usually takes care of updating all required settings.

Hope this helps.

|improve this answer|||||
  • Hi John, thanks for your advice on this. Sadly I had tried this before earlier yesterday and not had any joy. I have actually come across this issue in the past and used this method to resolve. Ideally keeping sef urls active would be better but at the moment I just want to get the front end working lol – Nick Apr 27 '18 at 8:15
  • 1
    Check the RewriteBase entry in the htaccess file. – Dennis Heiden May 3 '18 at 15:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.