0

The Blog article URL is like the following: http://example.com/en/index.php?option=com_content&view=article&id=166&Itemid=140. It only shows the modules that are assigned specifically to the homepage along with the article.

However, if I disable the Search Engine Friendly URLs in the admin settings, it works fine. It only happens to the blog article page, the blog overview page displays fine with proper modules. The Joomla version I am using is 3.6.5.

It only started happening recently, no module or Joomla update happened recently. Only new articles have been inserted, I tried disabling those articles too, no luck. Can someone guide on resolving this issue?

  • Are you using Advanced Module Manager or sh404 (or similar)? – Dennis Heiden Apr 26 '18 at 15:37
  • Nope, just the standard Joomla's SEO Friendly Url – Suthan Bala Apr 26 '18 at 16:41
2

It appears that specific version of Joomla had trouble getting the lang param. Changing the URL to http://example.com/index.php?option=com_content&view=article&id=166&Itemid=140&lang=en resolved it. Not sure how or why, but it works now.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.