0

Since today, one of our sites has a very strange behaviour:
- We cannot save most of our modules, it does not matter if we click save or save and close, it simply returns to the modules list, with all filters resetted
- The module remains blocked (not checked in)
- We can however save some modules (strangely, it does not matter the module position or type, even the standard custom module does not work)
- This happens to existing and new modules
- We tried to disable the Editor (JCE)
- Updated Joomla to 3.8.6
- Used another browser (FF + Chrome) + cleared the cache (Joomla-Cache too)
- Yesterday it worked, we only changed css since then
- Tried to compare the db-record of two modules (one thats working and one thats not), they are identical
- No JS-Errors in the console
- Joomla Debug-Console shows nothing suspicious

Is there any way to debug the saving-process?

Thanks in advance!

Update:
I finally managed to reproduce the issue in clear steps:
- If i assign the module to a few menu items only, i can save it without problems
- If i however set it to "All Pages", i can save it exactly one time, the second time i save the module, it does not work, there is a endless long array in the post data containing the single assignments (?!) to all menu items, but it does not contain the task variable wich says module.apply

So... is there any limit of number of menu items that i can assign modules to? (It is a huge site with countless menu items in 8 languages)

  • Just for clarification. This behaviour began on 3.8.5 and then continued after you upgraded to 3.8.6? – jamesgarrett Mar 20 '18 at 9:48
  • At 3.8.2, from wich we upgraded directly to 3.8.6 – pixx Mar 20 '18 at 10:17
  • Can you open a module, then open your browser console (F12) and report any console errors back. – Lodder Mar 20 '18 at 10:58
  • Strangely enough, there are no errors, just a warning that says: Empty string passed to getElementById In file: jquery.min.js:2:25285 – pixx Mar 20 '18 at 11:08
  • 2
    Are you hitting your max_input_vars? If your menu recently grew to near the 1000 default that would explain the sudden appearance. – jamesgarrett Mar 20 '18 at 22:49
0

As @jamesgarret mentioned,
we hit the max_input_vars limit, increased it to 2000, and the problem was solved!
Thanks!

  • Yeah, that problem has been there since forever and attempts to fix it a few years back stalled. Do mark your answer as complete so the question doesn’t remain unanswered. – jamesgarrett Mar 21 '18 at 9:28
  • Yes, it seems like, thanks again! I will... in 19 hours when Stackoverflow lets me accept it =) ) – pixx Mar 21 '18 at 13:50
  • 1
    It'd be kinda nice if you asked james to post this solution so that you could accept his answer. Perhaps he could include the process for how to increase the max_input_vars limit -- to offer a more comprehensive solution. This way he gets the credit for his insight (and you get more rep for accepting someone else's answer). – mickmackusa May 27 '18 at 12:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.