1

It looks like that I can't log in to my Joomla back end anymore. No error messages are shown, the log in screen just stays there. If I enter a wrong password on purpose, I get a warning that the username and password doesn't match.

All I did was that I made a backup of /components/com_users directory with a different name and deleted the original. I noticed that I made an error since I couldn't log in anymore and copied the directory back with the original com_users name. After this I couldn't log in either.

How do I fix my mistake?

  • Check the spelling, eg. com_users vs. com_user. Joomla relies on the naming to find the classes to load for internal processes. – nibra Mar 14 '18 at 17:14
  • Thank you for the comment, unfortunately com_user was just my writing typo. Just to be sure, I duplicated the directory so that I now have com_user and com_users but still no luck – olltsu Mar 14 '18 at 17:23
  • Thank you so much for this solution. I just upgraded to Joomla 3.8.10, as well as Community Builder and RSMembership. Then, I had the same problem of logging into the back end and front end. I still cannot pinpoint exactly how the plg_user_joomla was disabled in the extensions table, but at least it's fixed. Posting my steps here in case others experience the same scenario. – yaya Jul 3 '18 at 13:23
2

Solved my problem. this article helped me. The problem was solved by going to phpMyAdmin and searching for plg_user_joomla and changing it's enabled bit to 1.

Joomla probably disabled the user module when I tried to log in without the com_users component.

2

I had the same problem but after trying lot of things I found out that on my server php version was changed from 5.6 to newer 7.x version, and my version of joomla requires version 5.x. After I changed it back to 5.6 everything started to work as it was earlier.

So make sure that php version on server is supported by your version of joomla.

It is confusing that in most cases you can open your webpage and login administrator page, but can't login just because php version is not supported!

UPDATE

If you discover that this is problem, after you downgrade php version and joomla starts to work, then you should upgrade your joomla to newest version and then update php version on the server! Using updated php and joomla is very importat because you will get improved security and performance. (just to mention that old joomla sites can be easily hacked… and php 7.x is about 50% faster than 5.x…)

  • I am happy that you managed to remedy your issue and thank you for sharing your unsight, but advising others to downgrade their php version is not best practice -- it is more of a workaround. Using an up to date php version is not just important to enable better processing power and speed, it is also a matter of improved security. When you feel downgrading php or joomla is a solution, seek another solution. – mickmackusa Nov 21 '18 at 20:30
  • 1
    @mickmackusa Thank you for suggestion, You are right 100%, I edited comment to reflect your point. – omanosoft Nov 22 '18 at 7:31
0

I had this problem with these exact symptoms, and the culprit turned out to be that $cookie_domain was defined in configuration.php, and it had the wrong domain.

(This was a staging site, this site was a subdomain of the main domain.)

Setting $cookie_domain to '' or the correct domain fixed this issue.

0

Whenever this has occured for me I have overwritten all of the files with the original Joomla! files and that has resolved the problem. Hours of troubleshooting and a simple solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.