0

In layout override files, this is successfully outputting the content of the modules plus the icon for frontend module editing. But when clicked it opens the module editor as a full page instead of as a popup modal.

<?php echo JFactory::getDocument()->loadRenderer('modules')->render("MODULEPOSITION", array('style' => 'xhtml'), null); ?>

How to show the module editing page in a popup modal?

Also hope it's ok to ask two questions on one, how to have the module edit form return to the page on which the module is edited after clicking 'save' or 'cancel'? Currently it's returning to the sites index page.

0

This solved it for me not too long ago, when trying to use the K2 modal without succes:

  1. In override ../html/layouts/joomla/edit/frontediting_modules.php I extended line 34 with &tmpl=component&context=modalselector like this:

    $editUrl = JUri::base() . 'index.php?option=com_config&controller=config.display.modules&id=' . (int) $mod->id . '&Itemid=' . $itemid . $redirectUri .'&tmpl=component&context=modalselector';
    
  2. Make sure the main component is used/hidden on that page and you will be returned correctly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.