2

My Joomla editors are not working properly. When I save any HTML in editor, it changes its inline CSS or show it without CSS. I should also mention that CSS is not blocked in the joomla backend in any editor.

  • 1
    What editors are you using? JCE has a LOT of different settings so things can get overlooked. I use JCE and I have no problem putting most types of css inline. – Brian Peat Jun 12 '14 at 0:57
  • all editors causing this problem n by the way i m using TinyMCE. – Pooja Thakur Jun 13 '14 at 4:01
  • What are you trying to do exactly? When you use a WYWIWYG editor it will apply it's own inline css according to the editor options you apply. If you want to aply your own styles inline then toggle the editor off. – Seth Warburton Jun 18 '14 at 19:55
1

I had the same issue. I tried various settings (mentioned below) but ended up using Sourcerer http://www.nonumber.nl/extensions/sourcerer

You can quickly configure Joomla from stripping away your HTML tags by configuring your user groups ‘Filter Type’ to: ‘No Filtering’ or to your own preference for the respective Filter Groups.

By default JCK will strip a lot of CSS and it my case it was Glyphicons.

You can also set Global Config - Editor to 'none' which should allow you to type in pure code.

Personally I use JCE Editor which I find to be more capable.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.