1

In a backend component, I have one table that does not have numeric ID numbers. It is instead indexed on a unique alphanumeric value (think like a list of U.S. territories indexed on abbreviation, e.g. 'AZ'). I am working on building a simple view to display and edit these records, but Joomla! strips off the non-numeric ID numbers, removing the "id=" part of the query string altogether when I attempt to edit a record. Where in the system does this occur and can we safely override it?

2
  • It's your router file where this happens. check and fix router.php file.
    – Nagarjun
    Commented Jan 30, 2018 at 9:53
  • 1
    If he is doing this in the back end it has nothing to do with the router file since no routing is taking place.
    – Terry Carter
    Commented Feb 1, 2018 at 20:10

1 Answer 1

1

You have a couple of options here:

1) Easiest is to create a new auto increment field in your table and use that ID for your editing layout.

2) In your list view create a link that goes to the editing layout and rely on that link for getting to the editing screen. (example: index.php?option=my_component&view=my_view&layout=edit&my_alpha_id=123ABC&task=my_view.edit)

Be sure if you go the link route that you add the task URL Param to keep from getting errors. Also change the bold sections above to meet your needs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.