2

I have a module "login" wich represents a Login button. It's assigned to the possition "nav-helper".

This module dissapeared in the backend. When I search positions for "nav-helper" I only find the logout button. Even when I search for any module with "login" in it's name it does not come up.

However, the module is stilly properly displayed on the frontend and working.

I'm using Joomla 3.8.2 with the Porto template.

FYI the hompage wa just brought live on a different server. Everything else works. The only thing wrong is this one missing module.

Update: We got our development server back running, where I constructed and worked on the webpage before it was brought live on a different server. On this test server the module is still there. So it just vanished on our live joomla in the backend, and again it works fine on the frontend.

  • Does the login module appear for both logged in and logged out users? – TryHarder Nov 9 '17 at 13:46
  • I have exactly the same problem. I copied my prod to my test. Before the upgrade, I check and all the modules are there. After the upgrade (from 3.8.1 to 3.8.2), some modules are not showing in the backend. Modules working correctly in frontend. - It's not a filtering problem. - I can publish or unpublish modules directly in SQL. I compare the module table bewtween prod and test and the table seems identical. ---- EDIT --- After some investigation, All modules with access "Guest" do not display. And if I change a module from something to access Guest, it disappears from the backend list. – Eric Plante Nov 11 '17 at 3:13
2

https://github.com/joomla/joomla-cms/issues/18542

https://github.com/joomla/joomla-cms/pull/18335

So it is an issue caused by Joomla! only showing the modules of the current access level, so modules with guest access won't show unless you are logged in with that ACL. Links really explain it better and presumably will allow you to keep track if it is changed.

At the moment, you can change ACL for your account or the module.

  • Thank you. My module is set to Guest so it's very likely. – Julia Z Nov 14 '17 at 12:25
1

Typically, when this happens, it can be any of the following:

  • The module has been trashed (and maybe deleted), but the website is displaying a a cached version.
  • The module has been unpublished (and you are only searching for published modules), and the website is displaying a cached version. Deleting your Joomla cache will let you know whether the module has been trashed/deleted/unpublished.
  • The module still exists and is published, but you have some filtering set that prevents the module from being displayed.
  • You are logging in to the wrong website to edit your Joomla site.

Worst case scenario, just launch phpMyAdmin and search for the module name in the table #__modules.

  • the module has not been cached; I tried all possible filter options and could not find it.; I'm sadly also logged into the correct Joomla website; It looks like i need to check the phpMyAdmin tomorrow (thank you for this idea) – Julia Z Nov 9 '17 at 14:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.