1

I am running Joomla 3.3.0 on a VPS and it is extremely slow. In fact, it's the slowest I've ever seen Joomla load before (Can take upto 5 minutes to load the article editor!!).

Any ideas what could be causing it?

Components installed:

  • JCE Editor
  • K2
  • Mosets Tree
  • Xmap
  • Akeeba Admin Tools
  • Akeeba Backup
  • JComments

Running on:

  • PHP Version 5.3.10-1ubuntu3.11
  • Database Version 5.5.35-0ubuntu0.12.04.2
  • Web Server Apache/2.2.22 (Ubuntu)

I have tried disabling various plugins/extensions one by one but this doesn't seem to have solved it. I have also optimised the tables in the database (initially concentrating on the article tables) but again this didn't seem to make a difference.

Any help would be great! Thanks!

  • Try the Google page load checker, that will tell you if it is one script or all - and help pinpoint if it is site vs server developers.google.com/speed/pagespeed – tim.baker Jun 9 '14 at 9:09
  • Is this an established site? Was it migrated? – BodgeIT Jun 9 '14 at 13:23
3

If you have access to SSH try to use top/htop (may require root). This can tell you the cpu/ram usage that can point at server related issue.

Also try to create a file with php info

phpinfo.php

<?php
phpinfo();

Create this file and load it, does it load slow? That would point to the server as the main cause, if it loads fairly fast then it could be something to do with Joomla.

Another test is install a blank Joomla 3.3 site and see how it loads with full defaults.

If you have cpanel/plesk you can look into the resource usage as well, but both have different ways of doing it and can be dependent on plugins, so you would be on your own there but most likely there will be something to get that information.

If it ends up being server related the only hope is to either rebuild the vps (quicker sometimes) or try to fix it (update modules, check configs, ect).

If it is Joomla then it could be the php.ini settings or database (try an akeeba restore). If its php.ini in the extension manager and warnings you should see some sort of message about a setting that could be better.

However there is one last thing it could be, network.

5 minute load times would normally hit the php max_execution_time, so that makes me think its network connection. There is no way to really fix it other then time or talking to your host. It could also be the area you are in compared to the server (for that cloudflare or some other CDN service could help).

There are just some troubleshooting tips though, no guarantee that one of them is the answer, but a good place to start.

  • I've just used "Top" in SSH and it showed the following: Mem: 4048900k total, 3744012k used, 304888k free, 229596k buffers Swap: 4192252k total, 20564k used, 4171688k free, 2560892k cached Could it be related to this then? – RustyJoomla Jun 10 '14 at 11:24
1

The server specs seem perfectly fine and there's no reason why the extensions you have should be slowing down your site. All you have to ensure is you have the latest version of each one running. This seems like a server related issue rather than the site itself. It might be various reasons such as too much traffic for the server to handle, server issues at the host data center and so forth. It could simply be down to a really bad host. Not sure if you chose the cheap path or not but there always seems to be a catch with cheap hosting. Might be worth contacting your hosting provider to see if they can detect any issues.

  • Thanks for your comment. The VPS was setup by the company internally by our head of tech. I'll speak with him and see if he's got any ideas. Thanks again. – RustyJoomla Jun 9 '14 at 9:25
1

Is this an established site?
Was it upgraded from previous version? Have you tried rebuilding menus?

Check the Net tab in Firebug. This will show you which individual elements on the page are taking the longest to load. Often it's when you make offsite calls like to FB or other Social media...this can slow load times.

1

Ok, I've found the problem and resolved it.

The server drops any outbound packets where the target is the same as the source - a loopback. It does this for security reasons.

If there are several servers inside the firewall, if they call between themselves they need to use their external domain names, the fix is to set up your own internal DNS server that resolves domains names to internal ip address.

I fixed it by hacking the hosts file for now. but the above is the cause.

0

If it's a cheap VPS with low memory (RAM) you may be hitting some problems - try Joomla's debug / memory profiler (enable Debug in Global Configuration) and take a look there. I've had similar issues with ultra-low cost VPS providers and running out of memory.

Apache being slammed could also cause this - this'll slow your site to a crawl as well.

  • Thanks for your post. I'll take a look at the debug and see what it comes back with. – RustyJoomla Jun 9 '14 at 9:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.