UPDATE UPDATE UPDATE: Okay so all the emails ended up arriving, but they took anywhere from 30 minutes to 9 hours. Here's the raw message of one maybe osmeone can decipher it for me.

Delivered-To: my.email@gmail.com
Received: by 10.80.167.33 with SMTP id h30csp466605edc;
        Fri, 13 Oct 2017 01:18:39 -0700 (PDT)
X-Google-Smtp-Source: ABhQp+Rzp4OeWRIvPu0CmqRCXnVCX7Bqy4/HTaMJCNw4SFKdzMoUejiLhSkLhliGO+tFUfNeIGd9
X-Received: by 10.25.56.87 with SMTP id d23mr259389lfj.105.1507882719273;
        Fri, 13 Oct 2017 01:18:39 -0700 (PDT)
ARC-Seal: i=1; a=rsa-sha256; t=1507882719; cv=none;
        d=google.com; s=arc-20160816;
        b=bBSy1EhrN9i+2mMafrQINHL9nYODHU0AOyHb8nM1GmcEWFdbU4VzYnh4jTmLrNe6GB
         u7/0bOIQdYc0AzEBnT2SIG24oMycHSE1YgP8KDyaRB8EYM3BRoQY+qsS/QpfZHm0HP1R
         5nu9sfrTBY8umMgrmRQdh/yrGpQ72dKm0LuvIBTrCT6L+wXG+WxekK63c88R1VUIYcPI
         aasegde9/ACtBE7vkEuhKKUXIfKRA+2c4h8/49vuOH9sfHKkrwm6nDxgYYTCsD2fFHGM
         3DUf4jqmAcqQDAEk6axTzZKf2IFwTXwkc/RTyNSbDcRSBmw9bnGt6DicJkD15ps3YLRD
         zx+Q==
ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=google.com; s=arc-20160816;
        h=user-agent:message-id:subject:to:from:date:mime-version
         :dkim-signature:arc-authentication-results;
        bh=0RvcMnu5pCN2DOxALolDUYYsOEPvxq1yCTRb/oaIUXc=;
        b=pXw4YSY+D0CRZcnBSJkFTG/GSMfsuhCDmR/74V5AV08NA6AuquoxkUSTW6KJAHBo2w
         AWEHSZbZzC9qAB2mQWDVWxsMkcb4Z32/7aWXrNY7Y/auqoyPbmWL0eI0wnzZWwPD59Ie
         xexax1A7PzKNrUter7GAunwpJ3n/w5SH/8Y3sEYTdkUcJ/Hkdju5s5hkE/BsQ54ozZBj
         73b8qdId+We2QuN2LafbSMpXIZjdHfZ9y9RqFa6/stNjYdZ5ByeVOd4zXpFgsd+fdAhL
         aOCLVwfJe3AUui6ae0QAyAKqJyGKkcKq88AoKYtOXGcMovFtVcD0xDqpg26s5wZBlH4v
         +nWQ==
ARC-Authentication-Results: i=1; mx.google.com;
       dkim=pass header.i=@site.com.au header.s=default header.b=FH97vSCQ;
       spf=pass (google.com: domain of web@site.com.au designates 27.123.24.218 as permitted sender) smtp.mailfrom=web@site.com.au
Return-Path: 
Received: from server-62-r21.ipv4.au.syrahost.com (server-62-r21.ipv4.au.syrahost.com. [27.123.24.218])
        by mx.google.com with ESMTPS id o68si151052lfc.330.2017.10.13.01.18.37
        for 
        (version=TLS1_2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128);
        Fri, 13 Oct 2017 01:18:38 -0700 (PDT)
Received-SPF: pass (google.com: domain of web@site.com.au designates 27.123.24.218 as permitted sender) client-ip=27.123.24.218;
Authentication-Results: mx.google.com;
       dkim=pass header.i=@site.com.au header.s=default header.b=FH97vSCQ;
       spf=pass (google.com: domain of web@site.com.au designates 27.123.24.218 as permitted sender) smtp.mailfrom=web@site.com.au
Received: from server-6f-r7.ipv4.au.syrahost.com (unknown [27.124.114.231]) by halon-out02.au.ds.network (Halon) with ESMTPS id 4fe1de32-afa6-11e7-964f-f8bc1204ff90; Thu, 12 Oct 2017 23:37:29 +0000 (UTC)
DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed; d=site.com.au; s=default; h=Message-ID:Subject:To:From:Date: Content-Type:MIME-Version:Sender:Reply-To:Cc:Content-Transfer-Encoding: Content-ID:Content-Description:Resent-Date:Resent-From:Resent-Sender: Resent-To:Resent-Cc:Resent-Message-ID:In-Reply-To:References:List-Id: List-Help:List-Unsubscribe:List-Subscribe:List-Post:List-Owner:List-Archive;
     bh=0RvcMnu5pCN2DOxALolDUYYsOEPvxq1yCTRb/oaIUXc=; b=FH97vSCQ4JhFyeTLD1Ej+Pwyk psMsl88K08JiDEBryqgb6jv4vlVkQZTuO7dbEbUmKgyAAPbKmrZrODr7zr9uNx1S9UI3b1akzdtFo Ur+pRuT13efrIwpNUEuE1aNTlYqx3kjxqWPHXm+RQGwpQThu38efPOvB9Nv5FdVUrltCWTx+pRziW L23GceFqHfylsZl/oIKcfv2BcNrwWorJtAdX1BvX1lEuOtpzNjwl8ms3V+jEttma1uCIhaHe28tXs M3hodYKY9sLNYvbZVXQ9evLzS5gT/ZDCf0xAhRI+tgdXgfqJN/nUrwxPmG3+Cj7y2RpklMQsUht0d lVVREROtQ==;
Received: from webmailc2-w01.au.syrahost.com ([43.243.116.98]:43803 helo=webmail.au.syrahost.com) by webcloud25.au.syrahost.com with esmtpa (Exim 4.87) (envelope-from ) id 1e2n2W-001KCx-VF for my.email@gmail.com; Fri, 13 Oct 2017 07:37:29 +0800
Received: from xcD+OijFriZk7VgghWfLCGEXIguubc6cNFEMON8YQSEIMP9Aadni9A== (msLItenB1bKeZJlrmStJMfuFoA05lQ+4) by webmail.au.syrahost.com with HTTP (HTTP/1.1 POST); Fri, 13 Oct 2017 07:37:20 +0800
MIME-Version: 1.0
Content-Type: multipart/alternative; boundary="=_e266d617eac1f5608f5278983df8035b"
Date: Fri, 13 Oct 2017 01:37:20 +0200
From: web@site.com.au
To: my.email@gmail.com
Subject: This is a test email
Message-ID: 
X-Sender: web@site.com.au
User-Agent: My Webmail/0.9.5
X-OutGoing-Spam-Status: No, score=-1.9
X-AntiAbuse: This header was added to track abuse, please include it with any abuse report
X-AntiAbuse: Primary Hostname - webcloud25.au.syrahost.com
X-AntiAbuse: Original Domain - gmail.com
X-AntiAbuse: Originator/Caller UID/GID - [47 12] / [47 12]
X-AntiAbuse: Sender Address Domain - site.com.au
X-Get-Message-Sender-Via: webcloud25.au.syrahost.com: authenticated_id: web@site.com.au
X-Authenticated-Sender: webcloud25.au.syrahost.com: web@site.com.au
X-Source: 
X-Source-Args: 
X-Source-Dir: 

--=_e266d617eac1f5608f5278983df8035b
Content-Transfer-Encoding: 7bit
Content-Type: text/plain; charset=UTF-8




--=_e266d617eac1f5608f5278983df8035b
Content-Transfer-Encoding: quoted-printable
Content-Type: text/html; charset=UTF-8



 

  --=_e266d617eac1f5608f5278983df8035b--

UPDATE UPDATE: So the custom php code way down below that I used to send a test email ALSO successfully delivered - a few hours later.

UPDATE: It seems some emails are actually being sent, but they're taking over 30 minutes to arrive. So account activation emails are taking FOREVER, but all the other emails I previously listed as "working" are sent and received instantly.



X-Apparently-To: my.email@yahoo.com; Fri, 13 Oct 2017 01:39:17 +0000
Return-Path: 
Received-SPF: none (domain of webcloud25.au.syrahost.com does not designate permitted sender hosts)
X-YMailISG: HeBvuhkWLDs8ACNrj_JIUpnLan4ZwsGpB5jqRGn5STLHz5N2
 2G0T4zWC.4cYHw7Nt9R2VV1vvGJDtIqiSRSOjPVbqavWddQSbAndcjRxC365
 CPzLZiRqlLRkvIbAkQzW0dH8H_W0Y49lSFB68xU6fQole_KevllMq5a8N1GR
 vS_vfG4e5r6vNqAB53MgiP5jtF7vhkSwmFWkihix42t.f32nNr.7IbzXa8SL
 Nw37_IhzQknHW.9sHIPBXFP9637CplTNv10FGIBryvCLWCOQ3TWGVzC0gsxQ
 SQcEeQx4V3oZvdogbHRKlNoXKzwIM6qu8zckxMGwE1WcdR59UkjwE7ERKgfp
 65CbuzPR1zUshZq3bWLbNxt9q9.3.R6MmPvHIZzdWRPhV2RXTiOaYa9fgRQD
 Kzwj9KyUrohjSGRN5OIdtOuUFt.F2kDxwC199wdPWRHTevQksjSAl0xovu5c
 KA4M6t7V_8sS67XL5qeENnfuy1GZ8bcqm8aVIdaorxKvvEh_MIaW29PQaVLn
 mMb.u9PgHgl0BcVqsY63mSi6lrgGH0yGnlPZqO4.ijhCij3Na9lKRvYK8t_C
 4xnyjqUKZhhXvmyR27FGQPSEu9e6Wxj_cjNqAN606bEmNRL9o_O8Cd6mlTu_
 rRO6jKP_b96ZvHA.Rx7H.a22Cjb0j3PshMcHz4S0t5ssn9j_gXElFDJo0oES
 a1wV5oZTaDB9LC0_o7NVulCNPYMKAZLIOs4JVMEhg1szGeNXhznSLy3YsFGT
 JOwx3LQEdM2Rw53rhTCp9i6cUzgBXbJZSM1AydBmMY3Ig08xqFO.0ZTpBwTh
 d8L4oDsMzUqN7cdT0m3mkdtbVD5SSr5VhlDsYvxT85HEhX0ckdl.t6bMnQjv
 vvAtti.5bziGWuOupcHzHC.VP_xDOqmh1moe7DUDGmFJNxLXcwWz7LTNTKfu
 IzW_A1nr1PQt5.8MJPrDHGGkdIMjwYXy.hxJGoS7iY70jirKL_o.Y3LPnr8M
 QkNrmNDshRcrInxRd3v4KxGJH0gfBWtbSoJ8S8XboH9wBeKsydzqGXeM8WOJ
 loXzPD86sdXm_uREpefmmr9xDwBOID6K8_qwe4TIGLMRJQSS_Hk51jkBFkA3
 vulMvUPJJWsWpATO9KbanjHMGqf8_4ca4iMk8eDeyUyZwzO.D4zGXPECr2pG
 4.R8ptT0
X-Originating-IP: [27.123.24.221]
Authentication-Results: mta1557.mail.gq1.yahoo.com  from=site.com.au; domainkeys=neutral (no sig);  from=site.com.au; dkim=neutral (no sig)
Received: from 127.0.0.1  (EHLO server-65-r21.ipv4.au.syrahost.com) (27.123.24.221)
  by mta1557.mail.gq1.yahoo.com with SMTPS; Fri, 13 Oct 2017 01:39:16 +0000
Received: from server-6f-r7.ipv4.au.syrahost.com (unknown [27.124.114.231])
    by halon-out02.au.ds.network (Halon) with ESMTPS
    id 113bbcf3-afb5-11e7-964f-f8bc1204ff90;
    Fri, 13 Oct 2017 01:23:07 +0000 (UTC)
Received: from my.server by webcloud25.au.syrahost.com with local (Exim 4.87)
    (envelope-from )
    id 1e2ogj-002Pby-L5
    for my.email@yahoo.com; Fri, 13 Oct 2017 09:23:06 +0800
To: my.email@yahoo.com
Subject: Account Details for Test at Site
X-PHP-Script: site.com.au/index.php for 202.67.85.61
X-PHP-Filename: /path/my.server/public_html/site.com.au/index.php REMOTE_ADDR: 202.67.85.61
Date: Fri, 13 Oct 2017 01:22:57 +0000
From: Site Web 
Reply-To: Site Admin 
Message-ID: 
MIME-Version: 1.0
Content-Type: text/plain; charset=utf-8
X-OutGoing-Spam-Status: No, score=0.8
X-AntiAbuse: This header was added to track abuse, please include it with any abuse report
X-AntiAbuse: Primary Hostname - webcloud25.au.syrahost.com
X-AntiAbuse: Original Domain - yahoo.com
X-AntiAbuse: Originator/Caller UID/GID - [6406 498] / [47 12]
X-AntiAbuse: Sender Address Domain - webcloud25.au.syrahost.com
X-Get-Message-Sender-Via: webcloud25.au.syrahost.com: authenticated_id: my.server/from_h
X-Authenticated-Sender: webcloud25.au.syrahost.com: web@site.com.au
X-Source: 
X-Source-Args: /usr/sbin/proxyexec -q -d -s /var/lib/proxyexec/cagefs.sock/socket /bin/cagefs.server 
X-Source-Dir: /
Content-Length: 446

Hello Test,

Thank you for registering at Site. Your account is created and must be activated before you can use it.
To activate the account select the following link or copy-paste it in your browser:
https://site.com.au/login?task=registration.activate&token=7ae5bfdebc0e204a664175b96c632d0c 

After activation you may login to https://site.com.au/ using the following username and password:

Username: test
Password: 123456## Heading ##


Original

I'm having a problem getting Joomla to send the user registration / activation emails, and getting it to send the Test Email on the Server->Email settings section. I have multiple websites running on the server and they're all having the same issue. Joomla is up to date and PHP Version 7.0.23

I also tried just making a test php file:

    <?php
mail('my.email.address@gmail.com','This is a test message subject','This is a test message body');
echo 'Mail sent.'; 
?>

No errors come up, and the mail() call returns True, but nothing gets sent. The mail.log file shows

[13-Oct-2017 00:56:30 UTC] mail() on [/path/public_html/website.com.au/dev/mailtest.php:2]: To: my.email.address@gmail.com -- Headers: 

There aren't any email problems on other parts of the site.

  • Sending a mass mail works
  • Chronoforms is correctly sending emails
  • Creating a user in the backend of the page will send the "You have been added as a user" email
  • The site sends notifications when a Joomla update is available

I'm using PHP Mail - using SMTP is not really viable.


In the mail.log file I have two types of entries

  1. This is from using Mass Mail, and is an email that was actually sent

    [13-Oct-2017 00:21:32 UTC] mail() on [/path/public_html/site.com.au/libraries/vendor/phpmailer/phpmailer/class.phpmailer.php:700]: To: web@site.com.au -- Headers: Date: Fri, 13 Oct 2017 00:21:32 +0000 From: Ite Web  Bcc: andrew@site.com Message-ID:  MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8
  1. This is from user registration, and this email was NOT sent

    [13-Oct-2017 01:22:57 UTC] mail() on [/path/public_html/site.com.au/libraries/vendor/phpmailer/phpmailer/class.phpmailer.php:698]: To: my.email@yahoo.com -- Headers: Date: Fri, 13 Oct 2017 01:22:57 +0000 From: Site Web  Reply-To: Site Admin  Message-ID:  MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8

So the one that DOESN'T work goes to line 698 - and the line above that is


if (ini_get('safe_mode') or !$this->UseSendmailOptions or is_null($params)) {

So it appears user activation emails are being sent using SendmailOptions or something ? This shouldn't have any bearing on the custom PHP code not working though.

  • 1
    Have you tried contacting your hosting provider to see if they can shed some light on the matter? – Lodder Oct 13 '17 at 8:06
  • In the middle of that now. I'll post results to help others with the same problem if that's what it is. – Healyhatman Oct 14 '17 at 9:32
  • I did in fact get through to them and they did a bunch of tests and claimed everything was working fine and now, magically and for no reason I can discern, it is working fine. They claim they didn't change anything but who knows. – Healyhatman Oct 23 '17 at 5:26
  • Oh, well that's good news :) Would you mind adding that as a proper anseer below and marking it as accepted when possible? Thanks – Lodder Oct 23 '17 at 8:15
  • Not sure about that sorry. I didn't change anything and they claimed they didn't change anything, the problem that had persisted for weeks simply resolved itself. That doesn't help the next person that has this problem. – Healyhatman Oct 24 '17 at 21:09

As someone who administers mail servers - there are a couple of reasons this can happen.

  1. retry timing mismatch: The recipient server implements greylisting - requiring that the sending server retry the message at a later time, or they're just super busy and reject the message with a temporary error. Legitimate servers will do this, while spammers will just give up. The problem is the lack of standard retry time. My servers are configured to retry after 10 minutes, but I've seen some that don't retry for hours. I saw one configured for a 12 hour retry..... That's insane!

  2. Busy server - message is waiting in queue. If you're on a very busy mail server, your message might be accepted and queued for delivery. Being queued on a very busy server can mean a message waits for hours.

I started running my own mail servers years ago to avoid issues like this.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.