2

On a pretty new site, something has happened that has caused articles to give following error message upon saving (on frontend only)

Save failed with the following error: Invalid Parent ID

In search for a solution, I found that one reason for the error is that the category tree structure has gotten messed up for some reason and there seems to be many solutions. I first tried the following:

  • Rebuild all menu item
  • Rebuild all categories
  • Refresh all categories by edit and save/close
  • Refresh all articles by edit and save/close

As otherwised explained in this article: https://www.joomla-tips.org/joomla-troubleshooter/save-failed-with-the-following-error-invalid-parent-id.html

Iv'e also tried to create a temporary category and move all categories under it and back to root as explained in this article: https://www.itsupportguides.com/knowledge-base/joomla-tips/joomla-save-failed-with-the-following-error-invalid-parent-id/

However none of this seems to work. It is only when editing or creating articles on frontend I get this error message. Never been a issue when doing the same on backend, where it saves without any error.

Last thing I tried was to install the ACL Manager extension which also has a diagnostic tool to fix issues with assets tables. One was detected with com_category. However fixing it didn't solve it either.

Any help appreciated.

  • Can you try saving an article using the Protostar template in front-end and see what happens? – FFrewin Aug 25 '17 at 13:10
  • Our site uses a modified copy of protostar template. Switching to original protostar template, doesn't change much. Error still appears. Is by the way first time I've ever had this error message appear. – Marius Aug 25 '17 at 15:12
2

Maybe you are using Falang component? In my case only soultions was update PHP to 7.0 or 7.1 This problem exists since of Joomla 3.7.3 - it's all I know...

  • We did have the Falang component installed, never thought it could be a possible reason for the invalid error message. We use Falang on several other sites that are multilingual and running php 5.6. Will check there to see if they too are affected of this. We have however currently fixed the issue by reverting back to a state prior the issue, where we currently don't have the Falang component installed. If this issue appears again after installing Falang, I'll bring the issue to them. Thanks for the info. – Marius Aug 29 '17 at 8:49
1

This is indeed a issue caused by the Falang Componenet (2.9.1) with Joomla 3.7.3+.

The issue seems to be a problem with php 5 and the query used by Joomla in assets tables.

One way of fixing this is to update to php 7.0+ as @Tomasz Malinowski mentioned.

However updating to php 7.0+ can cause other errors if your site is not ready for it, as was my case.

So if you need to keep php 5 (in my case 5.6) then this fix works until a new version of Falang is released with a official fix.

In .../libraries/joomla/table/asset.php line 110 replace

->select('1')

with

->select($this->_db->quoteName('id'))

For Joomla 3.8+ the above line to replace is located in ...libraries/src/Table/Asset.php line 99

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.