3

I am following ine previous instructions to upgrade from 2.5.x to 2.5.28 in preparation to upgrade to 3.5. Install, DB steps went fine. 2 package updates were fine, but when I try to do Gantry to 4.1.33, whether through update or install, it throws this error:

Fatal error: Call to undefined method JInstallerPackage::getManifest() in /home1/someuser/public_html/joomlatest/tmp/install_599de020ec6ed/install.php on line 75
4
  • Post your issue at rocketheme support forum.
    – FFrewin
    Aug 23, 2017 at 21:10
  • Rocketheme support forum seems to only be available for paid subscriptions. The site I am working on is for a non-profit club with very limited budget.
    – JimR
    Aug 25, 2017 at 13:11
  • I have the same issue...have you found any solution? Thanks
    – musinfo
    Sep 29, 2017 at 14:32
  • This question is also asked at: stackoverflow.com/q/45862812/1983389 Sep 30, 2017 at 2:50

1 Answer 1

3

It looks like the last version of Gantry 4 that is supported on Joomla 2.5 is v4.1.32.

You can download Gantry v4.1.32 from:

http://gantry4.s3.amazonaws.com/releases/gantry_joomla_framework-4.1.32.zip

Upgrade to Gantry v4.1.32, migrate your Joomla 2.5 website to Joomla 3.x and then upgrade to the latest version of Gantry 4.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.