1

My client's site http://antoniniandcohen.com is automatically redirecting to /es/ rather than /en/ on the homepage, despite the fact that the site default language is English.

I'm not an expert in Joomla or Multilang, so here are some details:

Joomla! 3.2.7 Stable [ Ember ] 30-September-2014 14:00 GMT

Looking at the Language Manager Extension, I have 2 languages installed: English (default) and Spanish.

The Plugin System - Language Filter options are as follows:

Language Selection for new Visitors: Site Language
Automatic Language Change: Yes
Item associations: Yes
Remove URL Language Code: No
Cookie Lifetime: Session
Add alternate meta tags: Yes

Just to be sure, I checked the database and row named com_languages in the _extensions table has the following as params: {"administrator":"en-GB","site":"en-GB"}, so that seems to be good.

Here are some additional details and curiosities that I've been able to scrape together:

I put in an .htaccess rule to try to override this, and it is not working RedirectMatch 302 ^/$ /en

If you run the site with caches disabled, the error does NOT occur

I recently made an exact local copy of the site, and the error does NOT occur

When you visit the site and check the network log, there is a 303 redirect triggered for the /es/ site (details from redirect-checker.org):

> --------------------------------------------
> 303 See other
> --------------------------------------------

Status: 303 See other
Code:   303
Server: nginx/1.12.0
Date:   Sat, 08 Jul 2017 18:32:57 GMT
Content-Type:   text/html; charset=utf-8
Content-Length: 0
Connection: close
Location:   http://antoniniandcohen.com/es/
Cache-Control:  max-age=7200
Expires:    Sat, 08 Jul 2017 15:06:17 GMT
X-Endurance-Cache-Level:    2
X-Acc-Exp:  43200
X-Proxy-Cache:  HIT antoniniandcohen.com  

>>> http://antoniniandcohen.com/es/

> --------------------------------------------
> 200 OK
> -------------------------------------------- 

Status: 200 OK
Code:   200
Server: nginx/1.12.0
Date:   Sat, 08 Jul 2017 18:32:58 GMT
Content-Type:   text/html; charset=utf-8
Connection: close
P3P:    CP="NOI ADM DEV PSAi COM NAV OUR OTRo STP IND DEM"
Expires:    Mon, 1 Jan 2001 00:00:00 GMT
Cache-Control:  no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Pragma: no-cache
Set-Cookie: a5246ba9a44f358f1e9603d2d3209341=es-ES
Last-Modified:  Sat, 08 Jul 2017 18:32:58 GMT
X-Endurance-Cache-Level:    2
X-Acc-Exp:  43200
X-Proxy-Cache:  EXPIRED antoniniandcohen.com

Any idea what this could possibly be? Any help is appreciated because this is a bit over my head!

2

My client's host, Bluehost, has something called Endurance Cache enabled by default on all their sites. I'm not sure why an incorrect response got cached, but turning this caching mechanism off in their control panel fixed the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.