0

I have a client who is trying to follow a Udemy course which uses a template from 2014 with the Jgive component.

I have tried with different templates and the jQuery error does not appear, so it must be template related.

The code that is being flagged up is:

if(typeof(techjoomla)=="undefined"){var techjoomla={}}if(typeof(techjoomla.jQuery)=="undefined"){techjoomla.jQuery=jQuery.noConflict()};

With the error:

Uncaught ReferenceError: jQuery is not defined @ namespace.min.js:1 (anonymous) @ namespace.min.js:1

The error occurs on the last bit: =jQuery.noConflict()};

The page is located here although it does require registration to view the page - please feel free to register if need be, or if the error in the code is obvious, please let me know and I'll correct it and post back.

I have updated to Joomla 3.7.2 to see if the issue fixes itself but it does not unfortunately.

Thank you in advance Regards D

1

you need to load jQuery before the code you pasted is run, which is done automatically by most modern templates.

A quick solution is to open the template's index.php file and paste this at the beginning of the <head> section:

<head>
<script src="//ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js" type="text/javascript"></script>

if you still face errors after this it may be due to the code requiring an older jQuery, look here for a complete list.

An alternative and possibly easier way to achieve this is to install a plugin that will do it for you, for example jQuery easy.

  • Thanks Riccardo - I've tried using jQuery Easy, but the Jgive component still loads its own version of Jquery first. I have also manually added it into the Index.php of the template but it doesnt make a difference. If you have a look now, you will see the version I have added is way below the version the extension loads. Its frustrating to say the least. – Dtorr1981 Jun 30 '17 at 18:43
  • It seems to be an error loading no conflict. – Dtorr1981 Jun 30 '17 at 18:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.