2

This question has been asked on the developers Forum but got closed down with no answer. Not sure why. We have also contacted them directly but the response was to : ask some one else.

Megamenu duplicate menu items after T3 Framework updating to v 2.6

We update our modules etc regularly, but the menu on the website had not changed for a while. Now when changing the menu order in the normal Joomla menu interface, then menu items in the mega menu drop down get duplicated. Restoring them to the original order removes the issue (!)

This must have come in somewhere between versions 2.6.2 through 2.6.5. I am using Joomla 3.7.2.

I have tried a bit of debugging in the plugin, and the json on the DB that it uses, but I can't figure out at which point the menu gets duplicated.

Question : has anyone else came across this issue ? does it some familiar.

Very happy if it's something I've overlooked or that I've done, rather than a bug.

1

I recognise the silence when no one responds to your critical question! (In my experience it usually means that I'm the one at fault rather than the software but no one will point that out..).

This sounds like a good usage case for the "Rebuild" action in the menu manager if you haven't already used it.

Failing that and given that migration route you've taken - would it be feasible to simply rebuild the menu (not copy)to at least test if the issue persists on a "clean" menu?

  • Hi there - thanks for your response. I have tried rebuilding but to no affect. I have also tried recreating new menu items and re-arranging them, this gives a similar problem. I have not however, tried the proper investigation of " doing a fresh install, enabling only the required modules and see if it still occurs. This is what I need to do to really create a proper bug report for the developers. – jowan sebastian Jun 21 '17 at 10:38
  • Rebuidling the menu from Joomla has solved the exactly same problem for me. Joomla 3.8.1, T3 2.2.6 – Katja Oct 27 '17 at 8:49
1

I have had the same problem and managed to fix it. Goto template managerand click the mengamenu link.

When it loads your menu, click the menu that has the issue so it shows the duplicates. Then, turn OFF, submenu under Item Configuration. Turn it ON and it should be fixed.

If that does not work, turn it OFF, then save before turning it back on.

Doing this cleared the duplicated entries across all installed template sub versions I had on a site.

  • Many thanks for the reply. That didn't work in this case, but after an update to the modules and themes, doing this was needed to rebuild it. – jowan sebastian Aug 7 '17 at 10:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.