0

I am using a overide in template for my login module in joomla. I changed return value in the login form to a new redirection URL , which has query parameters along. This was working fine till I updated my site to https.(force https is also enabled from config) now the URL redirected is not having query parameers in it.

Following is what all I did:

<?php
$cnt="pagey";
$return_url = "https://example.com/index.php/new-page?var=".$cnt;
?>
<input id="return" type="hidden" name="return" value="<?php echo base64_encode($return_url); ?>" />

This should ideally redirect to the decoded value of URL along with params.

Expected: redirect after login to :

https://example.com/index.php/new-page?var=pagey

Current Output:

https://example.com/index.php/new-page

I tried base64_encode and decode of the url online, it is coming correct. But on browser only URL is seen without query parameters.

Can someone suggest on this

Thanks

  • If any of these apply, please update in your answer: Have code in htaccess forcing SSL, using the force SSL option in Global configuration or have 3rd party plugin for SSL. – YellowWebMonkey Jun 12 '17 at 11:05
  • I enabled force http in config,but how does that matter – user168983 Jun 13 '17 at 11:24
  • I poorly formed redirect can strip query strings. – YellowWebMonkey Jun 13 '17 at 12:02

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.