0

Just updated a site from 2.5 to 3.7.2 and now I can't access my smart search filter settings. When I go into one of them I'm supposed to see selections and checkboxes. See link. https://docs.joomla.org/Help37:Components_Finder_Manage_Search_Filters_Edit

Instead what I see is two toggle buttons that don't work. (screenshot 1)

Screenshot 1: screenshot1

Even weirder, here and here only, clicking the close button doesn't work. Instead I get a console error (screenshot2).

Screenshot 2: screenshot2

I've done all the standard troubleshooting, reininstall, going and getting the 3.7.2 files from a fresh download, updating all the things, changing my php version, looking for errors with maximum reporting, turning plugins on and off. I cannot figure out what's causing this. I have a secondary problem where my index isn't indexing any of the right values (that still exist in the database table as per previous version), but I can't really address that until I can actually see my filters.

I can't find anything about this, other than one thread here but I double checked, my files have the up-to-date code.

Any ideas anyone?

  • Have you tried it in a different browser (one you haven't accessed the site on before)? The javascript error is client side, and I've often found such errors end up being heavy browser caching or plugin conflicts. – Richard B Jun 2 '17 at 9:34
  • Sure have. I've tried Firefox, Chrome and Safari. – Faye Jun 2 '17 at 17:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.